aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJon Trowbridge <trow@ximian.com>2001-05-18 15:10:04 +0800
committerJon Trowbridge <trow@src.gnome.org>2001-05-18 15:10:04 +0800
commit3ca3f79dbe4641478582cd0b78a6e377c3430b19 (patch)
tree2693ebef04b05fff098f38f00233e676caf6229e /Makefile.am
parentc8476fc1ff4887bde985382de708f248067ac7ba (diff)
downloadgsoc2013-evolution-3ca3f79dbe4641478582cd0b78a6e377c3430b19.tar
gsoc2013-evolution-3ca3f79dbe4641478582cd0b78a6e377c3430b19.tar.gz
gsoc2013-evolution-3ca3f79dbe4641478582cd0b78a6e377c3430b19.tar.bz2
gsoc2013-evolution-3ca3f79dbe4641478582cd0b78a6e377c3430b19.tar.lz
gsoc2013-evolution-3ca3f79dbe4641478582cd0b78a6e377c3430b19.tar.xz
gsoc2013-evolution-3ca3f79dbe4641478582cd0b78a6e377c3430b19.tar.zst
gsoc2013-evolution-3ca3f79dbe4641478582cd0b78a6e377c3430b19.zip
Return the serialized EDestinations (rather than just a string w/ e-mail
2001-05-18 Jon Trowbridge <trow@ximian.com> * gui/component/select-names/e-select-names-bonobo.c (entry_get_property_fn): Return the serialized EDestinations (rather than just a string w/ e-mail addresses) through the bonobo component's property bag. * gui/component/select-names/e-select-names-model.c (e_select_names_model_export_destinationv): Added. A convenience routine for serializing the model's EDestinations into a string. * gui/component/select-names/e-select-names-popup.c (add_html_mail): Added. Puts in a check menu item for whether or not the recipient wants HTML mail. (popup_menu_card): Add menu item for HTML mail. Enable edit contact info item. (popup_menu_nocard): Add menu item for HTML mail. Enable edit contact info item. * backend/ebook/e-book-util.c (e_book_use_local_address_book): Added. Fetches the local addressbook and caches it on the first call. This is meant to be an easy and efficient way to get at the local addressbook with the minimum of code. (e_book_query_address_locally): Added. Convenience code that does an e-mail only e_book_name_and_email_query against the local address book. * backend/ebook/e-destination.c (e_destination_set_html_mail_pref): Added. Allows the intended recipient's HTML mail preference to be manipulated. (e_destination_get_email_verbose): Added. Cleaned up to use e_destination_get_name. (e_destination_get_html_mail_pref): Added. Read the recipient's HTML mail preference. If the destination is linked to a card, the preference is taken from the card (unless it has been explicitly overridden by a called to e_destination_set_html_mail_pref). (e_destination_get_address_textv): Added. Form a unified address string from a NULL-terminated vector of EDestinations. (e_destination_export): Added. Serialize an EDestination to a string. (e_destination_import): Added. Unserialize a string to build an EDestination. (e_destination_exportv): Added. Serialize a NULL-terminated vector of EDestinations to a string. (e_destination_importv): Added. Unserialize a string to build a NULL-terminated vector of EDestinations. * gui/component/select-names/e-select-names-completion.c: Implemented local versions of g_strcasecmp and g_strncasecmp (which should really be in glib, I think...) for utf8, and used them to make this code utf8-safe. 2001-05-18 Jon Trowbridge <trow@ximian.com> * Makefile.am (evolution_mail_LDADD): Added libebook.la (which is now required by the composer.) 2001-05-18 Jon Trowbridge <trow@ximian.com> * e-msg-composer-hdrs.c (set_recipients): Properly unserialize the string returned by the "text" property of the bonobo control, convert it into EDestinations, and use them to get the e-mail addresses of our recipients. 22001-05-18 Jon Trowbridge <trow@ximian.com> * Makefile.am (SUBDIRS): Changed build order. Now addressbook gets built before mail. svn path=/trunk/; revision=9878
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index a1fb079cde..5c72dc6a19 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -25,10 +25,10 @@ SUBDIRS = \
camel \
filter \
composer \
- mail \
libical \
libversit \
addressbook \
+ mail \
calendar \
wombat \
importers \