aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMatthew Barnes <mbarnes@redhat.com>2009-07-01 06:34:08 +0800
committerMatthew Barnes <mbarnes@redhat.com>2009-07-01 06:34:08 +0800
commitbfc5ba2511dc5fd9f5aa9868946c8860afad81bf (patch)
tree42c8edf720cd7a80c448da74f080ca1d6b80d56c /Makefile.am
parent8dc6bbd250891bcef9130a789c9b74a01be7f1cb (diff)
downloadgsoc2013-evolution-bfc5ba2511dc5fd9f5aa9868946c8860afad81bf.tar
gsoc2013-evolution-bfc5ba2511dc5fd9f5aa9868946c8860afad81bf.tar.gz
gsoc2013-evolution-bfc5ba2511dc5fd9f5aa9868946c8860afad81bf.tar.bz2
gsoc2013-evolution-bfc5ba2511dc5fd9f5aa9868946c8860afad81bf.tar.lz
gsoc2013-evolution-bfc5ba2511dc5fd9f5aa9868946c8860afad81bf.tar.xz
gsoc2013-evolution-bfc5ba2511dc5fd9f5aa9868946c8860afad81bf.tar.zst
gsoc2013-evolution-bfc5ba2511dc5fd9f5aa9868946c8860afad81bf.zip
Fix "make distcheck" errors and other build cleanups.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am18
1 files changed, 10 insertions, 8 deletions
diff --git a/Makefile.am b/Makefile.am
index d7c022c4ed..61c0a220a1 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -32,7 +32,11 @@ EXTRA_DIST = \
$(pkgconfig_DATA:.pc=.pc.in)
if ENABLE_SMIME
-SMIME_DIR=smime
+SMIME_SUBDIR=smime
+endif
+
+if WITH_HELP
+HELP_SUBDIR=help
endif
SUBDIRS = \
@@ -43,7 +47,7 @@ SUBDIRS = \
filter \
widgets \
shell \
- $(SMIME_DIR) \
+ $(SMIME_SUBDIR) \
em-format \
composer \
addressbook \
@@ -57,11 +61,8 @@ SUBDIRS = \
views \
tools \
po \
- sounds
-
-if WITH_HELP
-SUBDIRS += help
-endif
+ sounds \
+ $(HELP_SUBDIR)
DISTCLEANFILES = \
$(builddir)/doltcompile \
@@ -89,6 +90,7 @@ MAINTAINERCLEANFILES = \
DISTCHECK_CONFIGURE_FLAGS = \
--enable-gtk-doc \
--disable-scrollkeeper \
- --enable-test-component
+ --enable-test-component \
+ --with-help
-include $(top_srcdir)/git.mk