aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorDan Winship <danw@src.gnome.org>2003-01-06 22:16:59 +0800
committerDan Winship <danw@src.gnome.org>2003-01-06 22:16:59 +0800
commitcd6da3a0c9804ca8c75b69d47e16ca67847c0b1f (patch)
treefe838d4a92498422c881eee50260dc266d836c3e /Makefile.am
parentb993405d21997f28daa51eafb771f3185e1642bd (diff)
downloadgsoc2013-evolution-cd6da3a0c9804ca8c75b69d47e16ca67847c0b1f.tar
gsoc2013-evolution-cd6da3a0c9804ca8c75b69d47e16ca67847c0b1f.tar.gz
gsoc2013-evolution-cd6da3a0c9804ca8c75b69d47e16ca67847c0b1f.tar.bz2
gsoc2013-evolution-cd6da3a0c9804ca8c75b69d47e16ca67847c0b1f.tar.lz
gsoc2013-evolution-cd6da3a0c9804ca8c75b69d47e16ca67847c0b1f.tar.xz
gsoc2013-evolution-cd6da3a0c9804ca8c75b69d47e16ca67847c0b1f.tar.zst
gsoc2013-evolution-cd6da3a0c9804ca8c75b69d47e16ca67847c0b1f.zip
Use "Evolution", not "evolution", since that becomes the value of the
* configure.in (AC_INIT): Use "Evolution", not "evolution", since that becomes the value of the PACKAGE variable (privlibdir): parse $VERSION by hand since. EVOLUTION_MAJOR_VERSION, etc aren't defined any more (and trying to pass a variable to AC_INIT won't work). This and the above change fix the problem that privlibdir was being defined as "${libdir}/Evolution/." instead of "${libdir}/evolution/1.3" (GAL_VERSION): AC_SUBST this since it's needed in the .pc files (idldir): define this here rather than in each Makefile.am that needs it. (AC_OUTPUT): Add .pc files * Makefile.am (pkgconfig_DATA): Add pc files. (confexec_DATA): Remove this (fooConf.sh files) (SUBDIRS): Move filter earlier in the build. (I think it was calendar that depends on it now?) (%Conf.sh): Remove this. The .pc files are output by configure.in now. * camel.pc.in, evolution-addressbook.pc.in, evolution-calendar.pc.in, evolution-shell.pc.in: Replace the *Conf.sh files with these. In addition to the basic variables, include camel_providerdir (in camel.pc) and idldir, IDL_INCLUDES and privlibdir (in the others). svn path=/trunk/; revision=19241
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am36
1 files changed, 8 insertions, 28 deletions
diff --git a/Makefile.am b/Makefile.am
index 05b24c0f11..f059374d8d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,12 +1,12 @@
changelogs = \
ChangeLog
-confexecdir = $(libdir)
-confexec_DATA = \
- camelConf.sh \
- evolution_shellConf.sh \
- evolution_addressbookConf.sh \
- evolution_calendarConf.sh
+pkgconfigdir = $(libdir)/pkgconfig
+pkgconfig_DATA = \
+ camel.pc \
+ evolution-shell.pc \
+ evolution-addressbook.pc \
+ evolution-calendar.pc
EXTRA_DIST = \
AUTHORS \
@@ -20,7 +20,7 @@ EXTRA_DIST = \
xml-i18n-merge.in \
xml-i18n-update.in \
xml-i18n-extract.in \
- $(confexec_DATA:.sh=.sh.in)
+ $(pkgconfig_DATA:.pc=.pc.in)
SUBDIRS = \
data \
@@ -30,12 +30,12 @@ SUBDIRS = \
widgets \
shell \
camel \
+ filter \
libwombat \
addressbook \
calendar \
my-evolution \
art \
- filter \
composer \
mail \
ui \
@@ -46,26 +46,6 @@ SUBDIRS = \
# omf-install
-%Conf.sh: %Conf.sh.in Makefile
- sed -e 's?\@EVOLUTION_LIBDIR\@?$(EVOLUTION_LIBDIR)?g' \
- -e 's?\@EVOLUTION_DATADIR\@?$(EVOLUTION_DATADIR)?g' \
- -e 's?\@EVOLUTION_INCLUDEDIR\@?$(EVOLUTION_INCLUDEDIR)?g' \
- -e 's?\@CAMEL_INCLUDEDIR\@?$(CAMEL_INCLUDEDIR)?g' \
- -e 's?\@VERSION\@?$(VERSION)?g' \
- -e 's?\@privlibdir\@?$(privlibdir)?g' \
- -e 's?\@SHELL_LIBS\@?$(SHELL_LIBS)?g' \
- -e 's?\@SHELL_CFLAGS\@?$(SHELL_CFLAGS)?g' \
- -e 's?\@CAMEL_LIBS\@?$(CAMEL_LIBS)?g' \
- -e 's?\@CAMEL_CFLAGS\@?$(CAMEL_CFLAGS)?g' \
- -e 's?\@LDAP_LIBS\@?$(LDAP_LIBS)?g' \
- -e 's?\@LDAP_CFLAGS\@?$(LDAP_CFLAGS)?g' \
- -e 's?\@EVOLUTION_ADDRESSBOOK_LIBS\@?$(EVOLUTION_ADDRESSBOOK_LIBS)?g' \
- -e 's?\@EVOLUTION_ADDRESSBOOK_CFLAGS\@?$(EVOLUTION_ADDRESSBOOK_CFLAGS)?g' \
- -e 's?\@EVOLUTION_CALENDAR_LIBS\@?$(EVOLUTION_CALENDAR_LIBS)?g' \
- -e 's?\@EVOLUTION_CALENDAR_CFLAGS\@?$(EVOLUTION_CALENDAR_CFLAGS)?g' \
- < $(srcdir)/$< > $@.tmp \
- && mv $@.tmp $@
-
# CDE Stuff
if HAVE_DTAPPINTEGRATE