aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorChenthill Palanisamy <pchenthill@novell.com>2010-06-29 21:20:43 +0800
committerChenthill Palanisamy <pchenthill@novell.com>2010-06-29 21:21:49 +0800
commitd852bddc484166a06dc1bdd8ff362179e51f5a52 (patch)
tree34ced9fea677d2031facfe81dcbe025aacbd0f31 /Makefile.am
parent1bf64514ac3c962ebe98e31b4d2010e0e39a5092 (diff)
downloadgsoc2013-evolution-d852bddc484166a06dc1bdd8ff362179e51f5a52.tar
gsoc2013-evolution-d852bddc484166a06dc1bdd8ff362179e51f5a52.tar.gz
gsoc2013-evolution-d852bddc484166a06dc1bdd8ff362179e51f5a52.tar.bz2
gsoc2013-evolution-d852bddc484166a06dc1bdd8ff362179e51f5a52.tar.lz
gsoc2013-evolution-d852bddc484166a06dc1bdd8ff362179e51f5a52.tar.xz
gsoc2013-evolution-d852bddc484166a06dc1bdd8ff362179e51f5a52.tar.zst
gsoc2013-evolution-d852bddc484166a06dc1bdd8ff362179e51f5a52.zip
Use version 3.0 for evolution-<module>.pc files while compiling with gtk3. Set dependencies right between gtk3 and gtk2 compilations
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 13 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index a69c68694e..03870ac474 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,11 +1,24 @@
ACLOCAL_AMFLAGS=-I m4
pkgconfigdir = $(libdir)/pkgconfig
+INTERFACE_VERSION=3.0
+
+if ENABLE_GTK3
+%-$(INTERFACE_VERSION).pc: %.pc
+ cp $< $@
+
+pkgconfig_DATA = \
+ evolution-calendar-$(INTERFACE_VERSION).pc \
+ evolution-mail-$(INTERFACE_VERSION).pc \
+ evolution-plugin-$(INTERFACE_VERSION).pc \
+ evolution-shell-$(INTERFACE_VERSION).pc
+else
pkgconfig_DATA = \
evolution-calendar.pc \
evolution-mail.pc \
evolution-plugin.pc \
evolution-shell.pc
+endif
EXTRA_DIST = \
AUTHORS \