aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMatthew Barnes <mbarnes@redhat.com>2012-06-18 22:42:10 +0800
committerMatthew Barnes <mbarnes@redhat.com>2012-06-18 22:54:54 +0800
commit09fb1eb5151f551210ef4848463dc4caabf11911 (patch)
tree4f195227a195bfb37b5ab890b5431c4524c6187e /configure.ac
parentf2a2b68c527c93b3d5a2c73b9cca96a0ea420cd4 (diff)
downloadgsoc2013-evolution-09fb1eb5151f551210ef4848463dc4caabf11911.tar
gsoc2013-evolution-09fb1eb5151f551210ef4848463dc4caabf11911.tar.gz
gsoc2013-evolution-09fb1eb5151f551210ef4848463dc4caabf11911.tar.bz2
gsoc2013-evolution-09fb1eb5151f551210ef4848463dc4caabf11911.tar.lz
gsoc2013-evolution-09fb1eb5151f551210ef4848463dc4caabf11911.tar.xz
gsoc2013-evolution-09fb1eb5151f551210ef4848463dc4caabf11911.tar.zst
gsoc2013-evolution-09fb1eb5151f551210ef4848463dc4caabf11911.zip
Clarify that libcanberra-gtk3 is optional.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 5f52ae0332..87ac0276b1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -279,7 +279,10 @@ AC_ARG_ENABLE([canberra],
[enable_canberra="$enableval"], [enable_canberra=yes])
if test $enable_canberra = yes; then
- PKG_CHECK_MODULES([CANBERRA],[libcanberra-gtk3 >= libcanberra_gtk_minimum_version])
+ PKG_CHECK_MODULES([CANBERRA],[libcanberra-gtk3 >= libcanberra_gtk_minimum_version],,
+ [AC_MSG_ERROR([libcanberra-gtk3 not found (or version < libcanberra_gtk_minimum_version),
+ If you want to disable support for event sounds,
+ please append --disable-canberra to configure.])])
AC_DEFINE(HAVE_CANBERRA, 1, [Define if using Canberra and Canberra-GTK for sound])
fi
AC_SUBST(CANBERRA_CFLAGS)