aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorH.Habighorst <tearofadragon@googlemail.com>2009-06-21 10:26:59 +0800
committerMatthew Barnes <mbarnes@redhat.com>2009-06-21 10:26:59 +0800
commit32fc333d574bfaab498d705cd7bb9f085a3365a0 (patch)
tree7a0b3f45b1af412aafdad9bcae2046fba706be56 /configure.ac
parent966d067c0d79551b2cdb10a96a2a716744b8bd65 (diff)
downloadgsoc2013-evolution-32fc333d574bfaab498d705cd7bb9f085a3365a0.tar
gsoc2013-evolution-32fc333d574bfaab498d705cd7bb9f085a3365a0.tar.gz
gsoc2013-evolution-32fc333d574bfaab498d705cd7bb9f085a3365a0.tar.bz2
gsoc2013-evolution-32fc333d574bfaab498d705cd7bb9f085a3365a0.tar.lz
gsoc2013-evolution-32fc333d574bfaab498d705cd7bb9f085a3365a0.tar.xz
gsoc2013-evolution-32fc333d574bfaab498d705cd7bb9f085a3365a0.tar.zst
gsoc2013-evolution-32fc333d574bfaab498d705cd7bb9f085a3365a0.zip
Bug 586478 – Fix quoting in configure.ac
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 8 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index 234f9b61b5..3c2e95b6e5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -11,12 +11,13 @@ m4_define([evo_stable_version],
[evo_major_version.m4_eval(evo_minor_version - 1)],
[evo_version])])
-# Base version : This is for api/versioning tracking for things like bonobo .server files
-# This should always be the major/minor of the stable version or stable version to be
+# Base Version: This is for API/version tracking for things like
+# Bonobo server files. This should always be the major/minor of
+# the stable version or stable version to be.
m4_define([base_version], [2.28])
-# Upgrade Revision: This is for triggering migration calls between
-# varying versions. This should be reset to 0 whenever BASE_VERSION changes.
+# Upgrade Revision: This is for triggering migration calls between
+# varying versions. Reset to 0 whenever BASE_VERSION changes.
m4_define([upgrade_revision], [0])
AC_INIT(evolution, [evo_version], http://bugzilla.gnome.org/enter_bug.cgi?product=Evolution)
@@ -104,11 +105,11 @@ if test "$evo_version" != "$evo_stable_version"; then
[Define to the latest stable version if this version is unstable])
fi
-AC_SUBST([BASE_VERSION],[base-version])
-AC_DEFINE_UNQUOTED(BASE_VERSION, "$BASE_VERSION", [Base version (Major.Minor)])
+AC_SUBST([BASE_VERSION],[base_version])
+AC_DEFINE_UNQUOTED(BASE_VERSION, ["$BASE_VERSION"], [Base version (Major.Minor)])
AC_SUBST([UPGRADE_REVISION],[upgrade_revision])
-AC_DEFINE_UNQUOTED(UPGRADE_REVISION, "$UPGRADE_REVISION", [The number of times we've upgraded since the BASE_VERSION release])
+AC_DEFINE_UNQUOTED(UPGRADE_REVISION, ["$UPGRADE_REVISION"], [The number of times we've upgraded since the BASE_VERSION release])
AC_ISC_POSIX
AC_PROG_CC