aboutsummaryrefslogtreecommitdiffstats
path: root/calendar/gui/alarm-notify/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'calendar/gui/alarm-notify/Makefile.am')
-rw-r--r--calendar/gui/alarm-notify/Makefile.am58
1 files changed, 38 insertions, 20 deletions
diff --git a/calendar/gui/alarm-notify/Makefile.am b/calendar/gui/alarm-notify/Makefile.am
index a85e99a9cf..eedfb95040 100644
--- a/calendar/gui/alarm-notify/Makefile.am
+++ b/calendar/gui/alarm-notify/Makefile.am
@@ -1,21 +1,30 @@
-CORBA_GENERATED_H = \
- evolution-calendar.h
-CORBA_GENERATED_C = \
+CORBA_GENERATED = \
+ Evolution-Composer.h \
+ Evolution-Composer-common.c \
+ Evolution-Composer-skels.c \
+ Evolution-Composer-stubs.c \
+ evolution-calendar.h \
evolution-calendar-common.c \
evolution-calendar-skels.c \
evolution-calendar-stubs.c
-CORBA_GENERATED = $(CORBA_GENERATED_C) $(CORBA_GENERATED_H)
-idls = $(top_srcdir)/calendar/idl/evolution-calendar.idl
-idl_flags = $(IDL_INCLUDES)
+idls = \
+ $(top_srcdir)/composer/Evolution-Composer.idl \
+ $(top_srcdir)/calendar/idl/evolution-calendar.idl
-$(CORBA_GENERATED_H): $(idls)
+idl_flags = `$(GNOME_CONFIG) --cflags idl` -I $(datadir)/idl
+
+$(CORBA_GENERATED): $(idls)
+ $(ORBIT_IDL) $(idl_flags) $(srcdir)/../../../composer/Evolution-Composer.idl
$(ORBIT_IDL) $(idl_flags) $(top_srcdir)/calendar/idl/evolution-calendar.idl
-$(CORBA_GENERATED_C): $(CORBA_GENERATED_H)
+bin_PROGRAMS = evolution-alarm-notify
-privlibexec_PROGRAMS = evolution-alarm-notify
+noinst_LIBRARIES = libalarm.a
+libalarm_a_SOURCES = \
+ alarm.c \
+ alarm.h
INCLUDES = \
-DG_LOG_DOMAIN=\"evolution-alarm-notify\" \
@@ -25,18 +34,22 @@ INCLUDES = \
-I$(top_srcdir)/libical/src/libical \
-I$(top_builddir)/libical/src/libical \
-I$(top_srcdir)/widgets \
+ -I$(includedir) \
+ -DEVOLUTION_DATADIR=\""$(datadir)"\" \
-DEVOLUTION_GLADEDIR=\""$(gladedir)"\" \
- -DEVOLUTION_IMAGESDIR=\""$(imagesdir)"\" \
+ -DEVOLUTION_ICONSDIR=\""$(iconsdir)"\" \
-DEVOLUTION_LOCALEDIR=\""$(localedir)"\" \
$(EVOLUTION_CALENDAR_CFLAGS)
+iconsdir = $(datadir)/images/evolution
+
+gladedir = $(datadir)/evolution/glade
+
glade_DATA = \
alarm-notify.glade
evolution_alarm_notify_SOURCES = \
$(CORBA_GENERATED) \
- alarm.c \
- alarm.h \
alarm-notify.c \
alarm-notify.h \
alarm-notify-dialog.c \
@@ -50,22 +63,27 @@ evolution_alarm_notify_SOURCES = \
save.h
evolution_alarm_notify_LDADD = \
+ libalarm.a \
$(top_builddir)/calendar/cal-client/libcal-client.la \
$(top_builddir)/calendar/cal-util/libcal-util.la \
+ $(top_builddir)/libical/src/libical/libical-evolution.la \
+ $(top_builddir)/libwombat/libwombat.la \
+ $(top_builddir)/e-util/libeutil.la \
$(EVOLUTION_CALENDAR_LIBS)
-server_in_files = \
- GNOME_Evolution_Calendar_AlarmNotify.server.in.in
+evolution_alarm_notify_LDFLAGS = -export-dynamic
+
+oafdir = $(datadir)/oaf
+oaf_in_files = \
+ GNOME_Evolution_Calendar_AlarmNotify.oaf.in
-server_DATA = $(server_in_files:.server.in.in=.server)
-$(server_in_files:.server.in.in=.server.in): $(server_in_files)
- sed -e "s|\@LIBEXECDIR\@|$(privlibexecdir)|" $< > $@
+oaf_DATA = $(oaf_in_files:.oaf.in=.oaf)
-@INTLTOOL_SERVER_RULE@
+@XML_I18N_MERGE_OAF_RULE@
EXTRA_DIST = \
- $(server_DATA) \
- $(server_in_files) \
+ $(oaf_DATA) \
+ $(oaf_in_files) \
$(glade_DATA)
BUILT_SOURCES = $(CORBA_GENERATED)