aboutsummaryrefslogtreecommitdiffstats
path: root/camel/providers/nntp/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'camel/providers/nntp/Makefile.am')
-rw-r--r--camel/providers/nntp/Makefile.am28
1 files changed, 15 insertions, 13 deletions
diff --git a/camel/providers/nntp/Makefile.am b/camel/providers/nntp/Makefile.am
index 5ef9ba71f7..7761440f5f 100644
--- a/camel/providers/nntp/Makefile.am
+++ b/camel/providers/nntp/Makefile.am
@@ -8,30 +8,32 @@ camel_provider_DATA = libcamelnntp.urls
INCLUDES = -I../.. \
-I$(top_srcdir)/camel \
-I$(top_srcdir)/intl \
+ -I$(top_srcdir)/libibex \
-I$(top_srcdir)/e-util \
-I$(top_srcdir) \
-I$(includedir) \
- $(CAMEL_CFLAGS) \
- $(GNOME_INCLUDEDIR) \
- $(GTK_INCLUDEDIR) \
+ $(EXTRA_GNOME_CFLAGS) \
-DG_LOG_DOMAIN=\"camel-nntp-provider\"
libcamelnntp_la_SOURCES = \
+ camel-nntp-auth.c \
+ camel-nntp-folder.c \
+ camel-nntp-grouplist.c \
+ camel-nntp-newsrc.c \
camel-nntp-provider.c \
camel-nntp-store.c \
- camel-nntp-folder.c \
- camel-nntp-stream.c \
- camel-nntp-summary.c
+ camel-nntp-utils.c
libcamelnntpinclude_HEADERS = \
- camel-nntp-store.h \
+ camel-nntp-auth.h \
camel-nntp-folder.h \
- camel-nntp-stream.h \
- camel-nntp-summary.h
-
-noinst_HEADERS = \
- camel-nntp-private.h
+ camel-nntp-grouplist.h \
+ camel-nntp-newsrc.h \
+ camel-nntp-resp-codes.h \
+ camel-nntp-store.h \
+ camel-nntp-types.h \
+ camel-nntp-utils.h
-libcamelnntp_la_LDFLAGS = -avoid-version -module
+libcamelnntp_la_LDFLAGS = -version-info 0:0:0
EXTRA_DIST = libcamelnntp.urls