aboutsummaryrefslogtreecommitdiffstats
path: root/mail/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'mail/Makefile.am')
-rw-r--r--mail/Makefile.am87
1 files changed, 0 insertions, 87 deletions
diff --git a/mail/Makefile.am b/mail/Makefile.am
deleted file mode 100644
index 4757995bf1..0000000000
--- a/mail/Makefile.am
+++ /dev/null
@@ -1,87 +0,0 @@
-bin_PROGRAMS = evolution-mail test-mail
-
-providerdir = $(libdir)/evolution/camel-providers/$(VERSION)
-
-EXTRA_DIST = e-attchmt.png
-pkgdata_DATA = e-attchmt.png
-
-INCLUDES = \
- -I$(top_srcdir)/widgets \
- -I$(top_srcdir)/widgets/e-text \
- -I$(top_srcdir) \
- -I$(top_srcdir)/camel \
- -I$(top_builddir)/shell \
- $(BONOBO_HTML_GNOME_CFLAGS) \
- -DEVOLUTION_VERSION=\""$(VERSION)"\" \
- -DEVOLUTION_GLADEDIR=\""$(gladedir)"\" \
- -DEVOLUTION_ICONSDIR=\""$(iconsdir)"\" \
- -DEVOLUTION_LOCALEDIR=\""$(datadir)/locale"\" \
- -DCAMEL_PROVIDERDIR=\""$(providerdir)"\"
-
-EVOLUTION_MAIL_CORBA_GENERATED = \
- Mail.h \
- Mail-common.c \
- Mail-skels.c \
- Mail-stubs.c
-
-evolution_mail_SOURCES = \
- $(EVOLUTION_MAIL_CORBA_GENERATED) \
- folder-browser.c \
- folder-browser.h \
- folder-browser-factory.c \
- folder-browser-factory.h \
- mail-display.c \
- mail-display.h \
- mail-format.c \
- mail-format.h \
- mail-identify.c \
- mail-identify.h \
- mail-ops.c \
- mail-ops.h \
- main.c \
- message-list.c \
- message-list.h \
- session.c \
- session.h
-
-
-evolution_mail_LDADD = \
- ../shell/Evolution-common.o \
- ../shell/Evolution-stubs.o \
- ../shell/Evolution-skels.o \
- ../shell/evolution-service-repository.o \
- ../composer/libcomposer.la \
- ../widgets/e-table/libetable.a \
- ../widgets/e-text/libetext.a \
- ../camel/libcamel.la \
- ../e-util/libeutil.la \
- ../libibex/libibex.la \
- $(BONOBO_HTML_GNOME_LIBS) \
- -lunicode
-
-test_mail_SOURCES = \
- test-mail.c
-
-test_mail_LDADD = \
- $(BONOBO_HTML_GNOME_LIBS)
-
-
-GOAD_FILES = evolution-mail.gnorba
-OAF_FILES = evolution-mail.oafinfo
-
-if USING_OAF
-oafdir = $(datadir)/oaf
-oaf_DATA = $(OAF_FILES)
-else
-gnorbadir = $(sysconfdir)/CORBA/servers
-gnorba_DATA = $(GOAD_FILES)
-endif
-
-$(EVOLUTION_MAIL_CORBA_GENERATED): Mail.idl
- $(ORBIT_IDL) -I$(datadir)/idl -I`$(GNOME_CONFIG) --datadir`/idl -I$(srcdir) $(srcdir)/Mail.idl
-
-EXTRA_DIST = Mail.idl $(GOAD_FILES) $(OAF_FILES)
-
-dist-hook:
- -mkdir $(distdir)/pixmaps
- cp $(srcdir)/pixmaps/*.xpm $(distdir)/pixmaps