aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorXavier Claessens <xclaesse@src.gnome.org>2007-08-31 00:49:52 +0800
committerXavier Claessens <xclaesse@src.gnome.org>2007-08-31 00:49:52 +0800
commit0b0bb0f621d8e1cda1508d9062a279459fc3b955 (patch)
tree03ad0e8b2180f5e3d6821fbab6315b33c7baf4d8 /configure.ac
parent3a535643a694d0dd1bed8e0b7a2fd6fd21e6ee0c (diff)
downloadgsoc2013-empathy-0b0bb0f621d8e1cda1508d9062a279459fc3b955.tar
gsoc2013-empathy-0b0bb0f621d8e1cda1508d9062a279459fc3b955.tar.gz
gsoc2013-empathy-0b0bb0f621d8e1cda1508d9062a279459fc3b955.tar.bz2
gsoc2013-empathy-0b0bb0f621d8e1cda1508d9062a279459fc3b955.tar.lz
gsoc2013-empathy-0b0bb0f621d8e1cda1508d9062a279459fc3b955.tar.xz
gsoc2013-empathy-0b0bb0f621d8e1cda1508d9062a279459fc3b955.tar.zst
gsoc2013-empathy-0b0bb0f621d8e1cda1508d9062a279459fc3b955.zip
Completely reworked ContactList API. Fixes bug #471611, bug #467280, bug #459540 and bug #462907.
svn path=/trunk/; revision=280
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac100
1 files changed, 48 insertions, 52 deletions
diff --git a/configure.ac b/configure.ac
index c31afd82c..49a09b7b8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -155,62 +155,58 @@ AC_ARG_ENABLE(python,
[build python bindings to libempathy and libempathy-gtk]), ,
enable_python=auto)
-PKG_CHECK_MODULES(PYTHON_BINDING,
-[
- pygtk-2.0,
- glib-2.0 >= $GLIB_REQUIRED
- gobject-2.0
- gconf-2.0 >= $GCONF_REQUIRED
- libxml-2.0
- gnome-vfs-2.0
- libtelepathy >= $TELEPATHY_REQUIRED
- libmissioncontrol >= $MISSION_CONTROL_REQUIRED
- gtk+-2.0 >= $GTK_REQUIRED
- libglade-2.0 >= $LIBGLADE_REQUIRED
- libgnomeui-2.0
-], have_python="yes", have_python="no")
-
-if test "x$have_python" = "xno"; then
- if test "x$enable_python" = "xyes"; then
- AC_MSG_ERROR([Could not find python dependencies])
- fi
- enable_python="no (missing dependencies)"
+if test "x$enable_python" != "xno"; then
+ AM_PATH_PYTHON
+ if test -z "$PYTHON" ; then
+ have_python="no"
+ else
+ PKG_CHECK_MODULES(PYTHON_BINDING,
+ [
+ pygtk-2.0,
+ glib-2.0 >= $GLIB_REQUIRED
+ gobject-2.0
+ gconf-2.0 >= $GCONF_REQUIRED
+ libxml-2.0
+ gnome-vfs-2.0
+ libtelepathy >= $TELEPATHY_REQUIRED
+ libmissioncontrol >= $MISSION_CONTROL_REQUIRED
+ gtk+-2.0 >= $GTK_REQUIRED
+ libglade-2.0 >= $LIBGLADE_REQUIRED
+ libgnomeui-2.0
+ ], have_python="yes", have_python="no")
+ fi
else
- if test "x$enable_python" != "xno"; then
- AM_PATH_PYTHON
- if test -z "$PYTHON" ; then
- enable_python="no"
- else
- enable_python="yes"
- fi
- else
- enable_python="no (disabled)"
- fi
+ have_python=no
+fi
+
+if test "x$enable_python" = "xyes" -a "x$have_python" != "xyes"; then
+ AC_MSG_ERROR([Couldn't find python.])
fi
-AM_CONDITIONAL(HAVE_PYTHON, test x$enable_python = xyes)
+
+AM_CONDITIONAL(HAVE_PYTHON, test "x$have_python" = "xyes")
dnl -----------------------------------------------------------
AC_OUTPUT([
- Makefile
- data/Makefile
- data/empathy.desktop.in
- data/16x16/Makefile
- data/22x22/Makefile
- data/24x24/Makefile
- data/32x32/Makefile
- data/48x48/Makefile
- data/scalable/Makefile
- po/Makefile.in
- libempathy/Makefile
- libempathy/libempathy.pc
- libempathy-gtk/Makefile
- libempathy-gtk/libempathy-gtk.pc
- src/Makefile
- doc/Makefile
- doc/libempathy/Makefile
- doc/libempathy-gtk/Makefile
- python/Makefile
- python/pyempathy/Makefile
- python/pyempathygtk/Makefile
+ Makefile
+ data/Makefile
+ data/empathy.desktop.in
+ data/16x16/Makefile
+ data/22x22/Makefile
+ data/24x24/Makefile
+ data/32x32/Makefile
+ data/48x48/Makefile
+ data/scalable/Makefile
+ po/Makefile.in
+ libempathy/Makefile
+ libempathy/libempathy.pc
+ libempathy-gtk/Makefile
+ libempathy-gtk/libempathy-gtk.pc
+ src/Makefile
+ doc/Makefile
+ doc/libempathy/Makefile
+ doc/libempathy-gtk/Makefile
+ python/Makefile
+ python/pyempathy/Makefile
+ python/pyempathygtk/Makefile
])