aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorXavier Claessens <xavier.claessens@collabora.co.uk>2012-07-23 21:27:20 +0800
committerXavier Claessens <xavier.claessens@collabora.co.uk>2012-07-23 21:56:00 +0800
commit4d3c3a8e211febcbbd71ce451c7eb9cd67eecd85 (patch)
treed3c357d907eb90f5393075df3f4ee50c0dd35109 /configure.ac
parent670aec4ba8b16fbf35afdf65b65c1904872286dc (diff)
downloadgsoc2013-empathy-4d3c3a8e211febcbbd71ce451c7eb9cd67eecd85.tar
gsoc2013-empathy-4d3c3a8e211febcbbd71ce451c7eb9cd67eecd85.tar.gz
gsoc2013-empathy-4d3c3a8e211febcbbd71ce451c7eb9cd67eecd85.tar.bz2
gsoc2013-empathy-4d3c3a8e211febcbbd71ce451c7eb9cd67eecd85.tar.lz
gsoc2013-empathy-4d3c3a8e211febcbbd71ce451c7eb9cd67eecd85.tar.xz
gsoc2013-empathy-4d3c3a8e211febcbbd71ce451c7eb9cd67eecd85.tar.zst
gsoc2013-empathy-4d3c3a8e211febcbbd71ce451c7eb9cd67eecd85.zip
Do not install MC plugins into MC's prefix
MC and Empathy could be installed in different prefixes
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac22
1 files changed, 9 insertions, 13 deletions
diff --git a/configure.ac b/configure.ac
index 3c9435dc1..868b06409 100644
--- a/configure.ac
+++ b/configure.ac
@@ -458,12 +458,6 @@ if test "x$enable_goa" != "xno"; then
mission-control-plugins
goa-1.0 >= $GOA_REQUIRED
], have_goa="yes", have_goa="no")
-
- AC_MSG_CHECKING([Mission Control plugins dir])
- MISSION_CONTROL_PLUGINS_DIR=`pkg-config --variable=plugindir mission-control-plugins`
-
- AC_MSG_RESULT([$MISSION_CONTROL_PLUGINS_DIR])
- AC_SUBST(MISSION_CONTROL_PLUGINS_DIR)
else
have_goa=no
fi
@@ -518,13 +512,6 @@ if test "x$enable_ubuntu_online_accounts" != "xno"; then
libsignon-glib >= $LIBSIGNON_REQUIRED
], have_uoa="yes", have_uoa="no")
- # MC plugins dir
- AC_MSG_CHECKING([Mission Control plugins dir])
- MISSION_CONTROL_PLUGINS_DIR=`pkg-config --variable=plugindir mission-control-plugins`
-
- AC_MSG_RESULT([$MISSION_CONTROL_PLUGINS_DIR])
- AC_SUBST(MISSION_CONTROL_PLUGINS_DIR)
-
# provider plugin dir
AC_MSG_CHECKING([Accounts provider plugin dir])
ACCOUNTS_PROVIDER_PLUGIN_DIR=`pkg-config --variable=provider_plugindir account-plugin`
@@ -561,6 +548,15 @@ fi
AM_CONDITIONAL(HAVE_UOA, test "x$have_uoa" = "xyes")
+if test "x$have_uoa" = "xyes" -o "x$have_goa" = "xyes"; then
+ AC_MSG_CHECKING([Mission Control plugins dir])
+ MISSION_CONTROL_PLUGINS_DIR=${libdir}/mission-control-plugins.`pkg-config --variable=MCP_ABI_VERSION mission-control-plugins`
+
+ AC_MSG_RESULT([$MISSION_CONTROL_PLUGINS_DIR])
+ AC_SUBST(MISSION_CONTROL_PLUGINS_DIR)
+fi
+
+
# Help documentation
YELP_HELP_INIT