aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGuillaume Desmottes <guillaume.desmottes@collabora.co.uk>2009-05-25 19:02:36 +0800
committerGuillaume Desmottes <guillaume.desmottes@collabora.co.uk>2009-10-23 19:03:34 +0800
commit601e416af2bafa2b890b045139c9d50ed5aa9c65 (patch)
tree4ed6d1977b506cf2e77964832f2dfdc7d53ae804 /configure.ac
parent6931154a620290ec29a50c017d427586fe6d8a3f (diff)
downloadgsoc2013-empathy-601e416af2bafa2b890b045139c9d50ed5aa9c65.tar
gsoc2013-empathy-601e416af2bafa2b890b045139c9d50ed5aa9c65.tar.gz
gsoc2013-empathy-601e416af2bafa2b890b045139c9d50ed5aa9c65.tar.bz2
gsoc2013-empathy-601e416af2bafa2b890b045139c9d50ed5aa9c65.tar.lz
gsoc2013-empathy-601e416af2bafa2b890b045139c9d50ed5aa9c65.tar.xz
gsoc2013-empathy-601e416af2bafa2b890b045139c9d50ed5aa9c65.tar.zst
gsoc2013-empathy-601e416af2bafa2b890b045139c9d50ed5aa9c65.zip
copy version management from Gabble
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac22
1 files changed, 21 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 36cf1fd5f..17f58aecd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,24 @@
-AC_INIT(Empathy, 2.29.1, http://bugzilla.gnome.org/browse.cgi?product=empathy)
+# Making releases:
+# set the new version number:
+# odd minor -> development series
+# even minor -> stable series
+# increment micro for each release within a series
+# set empathy_nano_version to 0.
+
+m4_define([empathy_major_version], [2])
+m4_define([empathy_minor_version], [29])
+m4_define([empathy_micro_version], [1])
+m4_define([empathy_nano_version], [1])
+
+m4_define([empathy_base_version],
+ [empathy_major_version.empathy_minor_version.empathy_micro_version])
+m4_define([empathy_version],
+ [m4_if(empathy_nano_version, 0, [empathy_base_version],
+ [empathy_base_version].[empathy_nano_version])])
+
+AC_INIT(Empathy, empathy_version, http://bugzilla.gnome.org/browse.cgi?product=empathy)
+
+
AC_PREREQ(2.59)
AC_COPYRIGHT([
Copyright (C) 2003-2007 Imendio AB