aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGuillaume Desmottes <guillaume.desmottes@collabora.co.uk>2011-05-05 21:06:05 +0800
committerGuillaume Desmottes <guillaume.desmottes@collabora.co.uk>2011-06-08 17:27:26 +0800
commit76d23bc01b65271a4067a13a9f51037004019d42 (patch)
treef30bb2c91a190ebde2321604b8797454697eab7f /configure.ac
parentb98c0e0b2a91f7deec643288082c12d61982f575 (diff)
downloadgsoc2013-empathy-76d23bc01b65271a4067a13a9f51037004019d42.tar
gsoc2013-empathy-76d23bc01b65271a4067a13a9f51037004019d42.tar.gz
gsoc2013-empathy-76d23bc01b65271a4067a13a9f51037004019d42.tar.bz2
gsoc2013-empathy-76d23bc01b65271a4067a13a9f51037004019d42.tar.lz
gsoc2013-empathy-76d23bc01b65271a4067a13a9f51037004019d42.tar.xz
gsoc2013-empathy-76d23bc01b65271a4067a13a9f51037004019d42.tar.zst
gsoc2013-empathy-76d23bc01b65271a4067a13a9f51037004019d42.zip
add an optional dep on geocode-glib
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac30
1 files changed, 30 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 1692810bb..3e998de91 100644
--- a/configure.ac
+++ b/configure.ac
@@ -375,6 +375,35 @@ AC_SUBST(GEOCLUE_CFLAGS)
AC_SUBST(GEOCLUE_LIBS)
# -----------------------------------------------------------
+# location checks: geocode-glib
+# -----------------------------------------------------------
+AC_ARG_ENABLE(geocode,
+ AS_HELP_STRING([--enable-geocode=@<:@no/yes/auto@:>@],
+ [Enable geocode support]), ,
+ enable_geocode=auto)
+
+if test "x$enable_geocode" != "xno"; then
+ PKG_CHECK_MODULES(GEOCODE,
+ [
+ geocode-glib
+ ], have_geocode="yes", have_geocode="no")
+
+ if test "x$have_geoclue" = "xyes"; then
+ AC_DEFINE(HAVE_GEOCODE, 1, [Define if you have geocode])
+ fi
+else
+ have_geocode="no"
+fi
+
+if test "x$enable_geocode" = "xyes" -a "x$have_geocode" != "xyes"; then
+ AC_MSG_ERROR([Could not find geocode dependencies.])
+fi
+
+AM_CONDITIONAL(HAVE_GEOCODE, test "x$have_geocode" = "xyes")
+AC_SUBST(GEOCODE_CFLAGS)
+AC_SUBST(GEOCODE_LIBS)
+
+# -----------------------------------------------------------
# meego widgets support
# -----------------------------------------------------------
AC_ARG_ENABLE(meego,
@@ -525,6 +554,7 @@ Configure summary:
Spell checking (enchant)....: ${have_enchant}
Display maps (libchamplain).: ${have_libchamplain}
Location awareness (Geoclue): ${have_geoclue}
+ Geocode support (Geoclue): ${have_geocode}
Adium themes (Webkit).......: ${have_webkit}
Meego widgets ..............: ${have_meego}
Control center embedding....: ${have_control_center_embedding}