aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDanielle Madeley <danielle.madeley@collabora.co.uk>2011-11-07 09:03:50 +0800
committerDanielle Madeley <danielle.madeley@collabora.co.uk>2011-11-07 09:03:50 +0800
commit7c0dff773920a0796e079d5c79165a12fc7e8ddd (patch)
tree61c3c535adb7b034373cc3f7af53909d6e396044 /configure.ac
parentd12639558defd8be43dc0c5c43a80f6397900bd5 (diff)
downloadgsoc2013-empathy-7c0dff773920a0796e079d5c79165a12fc7e8ddd.tar
gsoc2013-empathy-7c0dff773920a0796e079d5c79165a12fc7e8ddd.tar.gz
gsoc2013-empathy-7c0dff773920a0796e079d5c79165a12fc7e8ddd.tar.bz2
gsoc2013-empathy-7c0dff773920a0796e079d5c79165a12fc7e8ddd.tar.lz
gsoc2013-empathy-7c0dff773920a0796e079d5c79165a12fc7e8ddd.tar.xz
gsoc2013-empathy-7c0dff773920a0796e079d5c79165a12fc7e8ddd.tar.zst
gsoc2013-empathy-7c0dff773920a0796e079d5c79165a12fc7e8ddd.zip
Make GOA optional again
There is an --disable-goa flag in Empathy's configure, which should be able to disable GOA, except it had been included as a required dependency. This patch makes it completely optional again. Fixes: https://bugzilla.gnome.org/show_bug.cgi?id=663442
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 5 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index c3a8dc66f..a5050f72e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -201,7 +201,6 @@ PKG_CHECK_MODULES(EMPATHY,
libpulse-mainloop-glib
webkitgtk-3.0 >= $WEBKIT_REQUIRED
libsoup-2.4
- goa-1.0 >= $GOA_REQUIRED
])
PKG_CHECK_MODULES(YELL, [telepathy-yell])
@@ -600,7 +599,7 @@ if test "x$enable_goa" != "xno"; then
PKG_CHECK_MODULES(GOA,
[
mission-control-plugins
- goa-1.0
+ goa-1.0 >= $GOA_REQUIRED
], have_goa="yes", have_goa="no")
AC_MSG_CHECKING([Mission Control plugins dir])
@@ -616,6 +615,10 @@ if test "x$enable_goa" = "xyes" -a "x$have_goa" != "xyes"; then
AC_MSG_ERROR([Could not find GOA dependencies.])
fi
+if test "x$have_goa" = "xyes"; then
+ AC_DEFINE(HAVE_GOA, 1, [Define to 1 to enable GNOME Online Accounts])
+fi
+
AM_CONDITIONAL(HAVE_GOA, test "x$have_goa" = "xyes")
# Optional dependency for avatar selection