aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDanielle Madeley <danielle.madeley@collabora.co.uk>2011-06-15 00:18:58 +0800
committerGuillaume Desmottes <guillaume.desmottes@collabora.co.uk>2011-09-06 13:37:07 +0800
commitb2c74dfc9854df75ed63ccc9f8eeda6d3f6fc71b (patch)
tree2b7320c4f16516640fe134ba55030a82d88d6b93 /configure.ac
parent2d762527c1291c0a0fedcc2ab153d947b1876435 (diff)
downloadgsoc2013-empathy-b2c74dfc9854df75ed63ccc9f8eeda6d3f6fc71b.tar
gsoc2013-empathy-b2c74dfc9854df75ed63ccc9f8eeda6d3f6fc71b.tar.gz
gsoc2013-empathy-b2c74dfc9854df75ed63ccc9f8eeda6d3f6fc71b.tar.bz2
gsoc2013-empathy-b2c74dfc9854df75ed63ccc9f8eeda6d3f6fc71b.tar.lz
gsoc2013-empathy-b2c74dfc9854df75ed63ccc9f8eeda6d3f6fc71b.tar.xz
gsoc2013-empathy-b2c74dfc9854df75ed63ccc9f8eeda6d3f6fc71b.tar.zst
gsoc2013-empathy-b2c74dfc9854df75ed63ccc9f8eeda6d3f6fc71b.zip
Initial work on a GNOME Online Accounts Mission Control plugin
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac31
1 files changed, 31 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 94ba3fe01..2b0d27607 100644
--- a/configure.ac
+++ b/configure.ac
@@ -580,6 +580,35 @@ fi
AM_CONDITIONAL(HAVE_NST, test "x$have_nst" = "xyes")
# -----------------------------------------------------------
+# goa-mc-plugin
+# -----------------------------------------------------------
+AC_ARG_ENABLE(goa,
+ AS_HELP_STRING([--enable-goa=@<:@no/yes/auto@:>@],
+ [build GOA MC plugin]), ,
+ enable_goa=auto)
+
+if test "x$enable_goa" != "xno"; then
+ PKG_CHECK_MODULES(GOA,
+ [
+ mission-control-plugins
+ goa-1.0
+ ], have_goa="yes", have_goa="no")
+
+ AC_MSG_CHECKING([Mission Control plugins dir])
+ MISSION_CONTROL_PLUGINS_DIR=`pkg-config --variable=plugindir mission-control-plugins`
+
+ AC_SUBST(MISSION_CONTROL_PLUGINS_DIR)
+else
+ have_goa=no
+fi
+
+if test "x$enable_goa" = "xyes" -a "x$have_goa" != "xyes"; then
+ AC_MSG_ERROR([Could not find GOA dependencies.])
+fi
+
+AM_CONDITIONAL(HAVE_GOA, test "x$have_goa" = "xyes")
+
+# -----------------------------------------------------------
# new, single-window control center
# -----------------------------------------------------------
AC_ARG_ENABLE(control_center_embedding,
@@ -664,6 +693,7 @@ AC_CONFIG_FILES([
libempathy-gtk/Makefile
src/Makefile
nautilus-sendto-plugin/Makefile
+ goa-mc-plugin/Makefile
help/Makefile
tests/Makefile
tests/interactive/Makefile
@@ -697,6 +727,7 @@ Configure summary:
Extras:
Nautilus-sendto plugin......: ${have_nst}
+ GOA MC plugin...............: ${have_goa}
Salut E-D-S support.........: ${with_eds}
Exp. Call channel handler...: ${have_call}
Exp. Call log support.......: ${have_call_logs}