aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorXavier Claessens <xclaesse@gmail.com>2007-08-20 03:50:24 +0800
committerXavier Claessens <xclaesse@src.gnome.org>2007-08-20 03:50:24 +0800
commitb5b294aaff557e837096aab6602fa690b22a84dc (patch)
tree7e39fb5d50d33dcbcb1ed605dc24ffe5d689091e /configure.ac
parent6a23f8cae6cde04e75e509f34dd2dc10adf8bdd2 (diff)
downloadgsoc2013-empathy-b5b294aaff557e837096aab6602fa690b22a84dc.tar
gsoc2013-empathy-b5b294aaff557e837096aab6602fa690b22a84dc.tar.gz
gsoc2013-empathy-b5b294aaff557e837096aab6602fa690b22a84dc.tar.bz2
gsoc2013-empathy-b5b294aaff557e837096aab6602fa690b22a84dc.tar.lz
gsoc2013-empathy-b5b294aaff557e837096aab6602fa690b22a84dc.tar.xz
gsoc2013-empathy-b5b294aaff557e837096aab6602fa690b22a84dc.tar.zst
gsoc2013-empathy-b5b294aaff557e837096aab6602fa690b22a84dc.zip
Add python binding. Fixes bug #457660 (Michael Sheldon).
2007-08-19 Xavier Claessens <xclaesse@gmail.com> * python/pyempathy/pyempathy.defs: * python/pyempathy/pyempathymodule.c: * python/pyempathy/Makefile.am: * python/pyempathy/pyempathy.override: * python/pyempathygtk/pyempathygtk.override: * python/pyempathygtk/pyempathygtk.defs: * python/pyempathygtk/Makefile.am: * python/pyempathygtk/pyempathygtkmodule.c: * python/Makefile.am: * libempathy/empathy-time.h: * configure.ac: * Makefile.am: Add python binding. Fixes bug #457660 (Michael Sheldon). svn path=/trunk/; revision=264
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac43
1 files changed, 42 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 74ea426c3..f582d2bd7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -145,7 +145,46 @@ if test "x$enable_aspell" = "xyes" -a "x$have_aspell" != "xyes"; then
AC_MSG_ERROR([Couldn't find aspell.])
fi
+
+dnl -----------------------------------------------------------
+dnl Python Bindings
dnl -----------------------------------------------------------
+AC_ARG_ENABLE(python,
+ AS_HELP_STRING([--enable-python=@<:@no/yes/auto@:>@],
+ [build python bindings to libempathy and libempathy-gtk]), ,
+ enable_python=auto)
+
+PKG_CHECK_MODULES(PYTHON_BINDING,
+[
+ pygtk-2.0,
+ glib-2.0 >= $GLIB_REQUIRED
+ gobject-2.0
+ gconf-2.0 >= $GCONF_REQUIRED
+ libxml-2.0
+ gnome-vfs-2.0
+ libtelepathy >= $TELEPATHY_REQUIRED
+ libmissioncontrol >= $MISSION_CONTROL_REQUIRED
+ gtk+-2.0 >= $GTK_REQUIRED
+ libglade-2.0 >= $LIBGLADE_REQUIRED
+ libgnomeui-2.0
+], have_python="yes", have_python="no")
+
+if test "x$have_python" = "xno"; then
+ if test "x$enable_python" = "xyes"; then
+ AC_MSG_ERROR([Could not find python dependencies])
+ fi
+ enable_python="no (missing dependencies)"
+else
+ if test "x$enable_python" != "xno"; then
+ enable_python="yes"
+ else
+ enable_python="no (disabled)"
+ fi
+fi
+AM_CONDITIONAL(HAVE_PYTHON, test x$enable_python = xyes)
+
+dnl -----------------------------------------------------------
+
AC_OUTPUT([
Makefile
data/Makefile
@@ -164,5 +203,7 @@ AC_OUTPUT([
doc/Makefile
doc/libempathy/Makefile
doc/libempathy-gtk/Makefile
+ python/Makefile
+ python/pyempathy/Makefile
+ python/pyempathygtk/Makefile
])
-