aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorTravis Reitter <treitter@gmail.com>2010-05-29 07:13:51 +0800
committerTravis Reitter <treitter@gmail.com>2010-07-21 07:12:35 +0800
commitd6aa2f99e3e626f81b455c0fa1ff4817a4e4f2f6 (patch)
tree3db6a726bcc50a3423f601b7975d7abb166cb9a1 /configure.ac
parent57a1f36eaec69df0195e90d8a4b050574a19d6b3 (diff)
downloadgsoc2013-empathy-d6aa2f99e3e626f81b455c0fa1ff4817a4e4f2f6.tar
gsoc2013-empathy-d6aa2f99e3e626f81b455c0fa1ff4817a4e4f2f6.tar.gz
gsoc2013-empathy-d6aa2f99e3e626f81b455c0fa1ff4817a4e4f2f6.tar.bz2
gsoc2013-empathy-d6aa2f99e3e626f81b455c0fa1ff4817a4e4f2f6.tar.lz
gsoc2013-empathy-d6aa2f99e3e626f81b455c0fa1ff4817a4e4f2f6.tar.xz
gsoc2013-empathy-d6aa2f99e3e626f81b455c0fa1ff4817a4e4f2f6.tar.zst
gsoc2013-empathy-d6aa2f99e3e626f81b455c0fa1ff4817a4e4f2f6.zip
Base the contact list around libfolks metacontacts. Not yet to feature-parity
with mainline Empathy.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac28
1 files changed, 28 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 128628f34..cadebc867 100644
--- a/configure.ac
+++ b/configure.ac
@@ -31,6 +31,7 @@ AC_COPYRIGHT([
# Minimal version required
# Hardp deps
+FOLKS_REQUIRED=0.1.0
GCONF_REQUIRED=1.2.0
GLIB_REQUIRED=2.25.9
GTK_REQUIRED=2.21.2
@@ -140,6 +141,31 @@ AS_COMPILER_FLAG(-Wmissing-declarations, ERROR_CFLAGS="$ERROR_CFLAGS -Wmissing-d
AC_SUBST(ERROR_CFLAGS)
# -----------------------------------------------------------
+# Enable TPL
+# -----------------------------------------------------------
+
+# It needs to be defined before PKG_CHECK_MODULES calls
+AC_ARG_ENABLE(tpl,
+ AC_HELP_STRING([--enable-tpl],[enable telepathy-logger code and disable the
+ empathy logger]), enable_tpl=$enableval, enable_tpl=no )
+AM_CONDITIONAL(ENABLE_TPL, test "x$enable_tpl" = "xyes")
+
+if test x${enable_tpl} = xyes; then
+ AC_DEFINE(ENABLE_TPL, [], [Enable TPL code])
+fi
+
+if test "x$enable_tpl" = "xyes"; then
+ PKG_CHECK_MODULES(TPL,
+ [
+ telepathy-logger = $TELEPATHY_LOGGER
+ ])
+ AC_SUBST(TPL_CFLAGS)
+ AC_SUBST(TPL_LIBS)
+fi
+
+
+
+# -----------------------------------------------------------
# Pkg-Config dependency checks
# -----------------------------------------------------------
@@ -147,6 +173,8 @@ PKG_CHECK_MODULES(EMPATHY,
[
dbus-glib-1
farsight2-0.10
+ folks >= $FOLKS_REQUIRED
+ folks-telepathy >= $FOLKS_REQUIRED
gconf-2.0 >= $GCONF_REQUIRED
gio-2.0 >= $GLIB_REQUIRED
gio-unix-2.0 >= $GLIB_REQUIRED