aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorEmilio Pozuelo Monfort <emilio.pozuelo@collabora.co.uk>2011-08-16 19:56:12 +0800
committerEmilio Pozuelo Monfort <emilio.pozuelo@collabora.co.uk>2011-08-16 20:05:00 +0800
commite239157c776847fc577662752a5b49cd559b4a38 (patch)
tree3a695b01fb3b679438238aaeffb8d97dad01b905 /configure.ac
parent31ff17d78a1ab727dad9ed67e4ed6948ff118966 (diff)
downloadgsoc2013-empathy-e239157c776847fc577662752a5b49cd559b4a38.tar
gsoc2013-empathy-e239157c776847fc577662752a5b49cd559b4a38.tar.gz
gsoc2013-empathy-e239157c776847fc577662752a5b49cd559b4a38.tar.bz2
gsoc2013-empathy-e239157c776847fc577662752a5b49cd559b4a38.tar.lz
gsoc2013-empathy-e239157c776847fc577662752a5b49cd559b4a38.tar.xz
gsoc2013-empathy-e239157c776847fc577662752a5b49cd559b4a38.tar.zst
gsoc2013-empathy-e239157c776847fc577662752a5b49cd559b4a38.zip
Use AC_ARG_ENABLE with --enable-*
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 10 insertions, 10 deletions
diff --git a/configure.ac b/configure.ac
index e5366137a..429460276 100644
--- a/configure.ac
+++ b/configure.ac
@@ -189,11 +189,11 @@ PKG_CHECK_MODULES(EMPATHY_AV,
# -----------------------------------------------------------
# Call interface
# -----------------------------------------------------------
-AC_ARG_WITH(call,
- AC_HELP_STRING([--enable-call=@<:@no/yes/auto@:>@],
+AC_ARG_ENABLE(call,
+ AS_HELP_STRING([--enable-call=@<:@no/yes/auto@:>@],
[build with Call interface support]),,
- [with_call=auto])
-if test "x$with_call" != "xno" ; then
+ [enable_call=auto])
+if test "x$enable_call" != "xno" ; then
PKG_CHECK_MODULES(EMPATHY_CALL,
[
farsight2-0.10
@@ -210,7 +210,7 @@ else
have_call=no
fi
-if test "x$with_call" = "xyes" -a "x$have_call" != "xyes"; then
+if test "x$enable_call" = "xyes" -a "x$have_call" != "xyes"; then
AC_MSG_ERROR([Could not find Call handler dependencies.])
fi
AM_CONDITIONAL(HAVE_CALL, test "x$have_call" = "xyes")
@@ -219,11 +219,11 @@ AM_CONDITIONAL(HAVE_CALL, test "x$have_call" = "xyes")
# -----------------------------------------------------------
# Call support in tp-logger
# -----------------------------------------------------------
-AC_ARG_WITH(call-logs,
- AC_HELP_STRING([--enable-call-logs=@<:@no/yes/auto@:>@],
+AC_ARG_ENABLE(call-logs,
+ AS_HELP_STRING([--enable-call-logs=@<:@no/yes/auto@:>@],
[build with call logs support]),,
- [with_call_logs=auto])
-if test "x$with_call_logs" != "xno" ; then
+ [enable_call_logs=auto])
+if test "x$enable_call_logs" != "xno" ; then
SAVE_CFLAGS=$CFLAGS
SAVE_CPPFLAGS=$CPPFLAGS
CFLAGS="$CFLAGS $EMPATHY_CFLAGS"
@@ -242,7 +242,7 @@ else
have_call_logs=no
fi
-if test "x$with_call_logs" = "xyes" -a "x$have_call_logs" != "xyes"; then
+if test "x$enable_call_logs" = "xyes" -a "x$have_call_logs" != "xyes"; then
AC_MSG_ERROR([Call logs support requested but telepathy-logger wasn't
built with --enable-call])
fi