aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGustavo Noronha Silva <gns@gnome.org>2010-02-19 00:30:49 +0800
committerGustavo Noronha Silva <gns@gnome.org>2010-02-23 02:57:11 +0800
commit3e0f7dea754381c5ad11a06ccc62eb153382b498 (patch)
tree35942df25ac30024cf38d1e5c73961db128f40d9 /configure.ac
parenta5858387b3bba793a65d8bd262e122604529045f (diff)
downloadgsoc2013-epiphany-3e0f7dea754381c5ad11a06ccc62eb153382b498.tar
gsoc2013-epiphany-3e0f7dea754381c5ad11a06ccc62eb153382b498.tar.gz
gsoc2013-epiphany-3e0f7dea754381c5ad11a06ccc62eb153382b498.tar.bz2
gsoc2013-epiphany-3e0f7dea754381c5ad11a06ccc62eb153382b498.tar.lz
gsoc2013-epiphany-3e0f7dea754381c5ad11a06ccc62eb153382b498.tar.xz
gsoc2013-epiphany-3e0f7dea754381c5ad11a06ccc62eb153382b498.tar.zst
gsoc2013-epiphany-3e0f7dea754381c5ad11a06ccc62eb153382b498.zip
Report broken certs through the padlock icon
This uses a new feature in libsoup that reports through a SoupMessageFlag whether the message is talking to a server that has a trusted server. Bug #600663
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac36
1 files changed, 35 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index c177e76f1..37b98d7fc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -247,6 +247,39 @@ fi
AM_CONDITIONAL([ENABLE_SEED],[test "$enable_seed" = "yes"])
+# *********************
+# CA Certificate file
+# Stolen from GIO's TLS
+# *********************
+
+AC_MSG_CHECKING([location of system Certificate Authority list])
+AC_ARG_WITH(ca-file,
+ [AC_HELP_STRING([--with-ca-file=@<:@path@:>@],
+ [path to system Certificate Authority list])])
+if test "$with_ca_file" = "no"; then
+ AC_MSG_RESULT([disabled])
+else
+ if test -z "$with_ca_file"; then
+ for f in /etc/pki/tls/certs/ca-bundle.crt \
+ /etc/ssl/certs/ca-certificates.crt; do
+ if test -f "$f"; then
+ with_ca_file="$f"
+ fi
+ done
+ if test -z "$with_ca_file"; then
+ AC_MSG_ERROR([could not find. Use --with-ca-file=path to set, or --without-ca-file to disable])
+ fi
+ fi
+
+ AC_MSG_RESULT($with_ca_file)
+ if ! test -f "$with_ca_file"; then
+ AC_MSG_ERROR([No such file '$with_ca_file'. Use --with-ca-file=path to set, or --without-ca-file to disable])
+ fi
+ GTLS_SYSTEM_CA_FILE="$with_ca_file"
+
+ AC_DEFINE_UNQUOTED([GTLS_SYSTEM_CA_FILE], ["$GTLS_SYSTEM_CA_FILE"], [path to system Certificate Authority list])
+fi
+
# ***
# NSS
# ***
@@ -456,5 +489,6 @@ Epiphany was configured with the following options:
GObject introspection : $found_introspection
Seed support : $enable_seed
NSS support : $enable_nss
- Build tests : $enable_tests
+ Build tests : $enable_tests
+ CA Certificates file : $GTLS_SYSTEM_CA_FILE
"