aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Persch <chpe@src.gnome.org>2009-02-07 23:01:40 +0800
committerChristian Persch <chpe@src.gnome.org>2009-02-07 23:01:40 +0800
commit642eb45983933bf096844c0acb6b841fd5fa9ad3 (patch)
tree0dab374171c9ae190c2b82142d4fb208483f4360 /configure.ac
parent2e94ce01ab4c2e802e3123cdf325be4c10af6a59 (diff)
downloadgsoc2013-epiphany-642eb45983933bf096844c0acb6b841fd5fa9ad3.tar
gsoc2013-epiphany-642eb45983933bf096844c0acb6b841fd5fa9ad3.tar.gz
gsoc2013-epiphany-642eb45983933bf096844c0acb6b841fd5fa9ad3.tar.bz2
gsoc2013-epiphany-642eb45983933bf096844c0acb6b841fd5fa9ad3.tar.lz
gsoc2013-epiphany-642eb45983933bf096844c0acb6b841fd5fa9ad3.tar.xz
gsoc2013-epiphany-642eb45983933bf096844c0acb6b841fd5fa9ad3.tar.zst
gsoc2013-epiphany-642eb45983933bf096844c0acb6b841fd5fa9ad3.zip
Add gobject introspection support; use --enable-introspection.
svn path=/trunk/; revision=8755
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac44
1 files changed, 42 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 8f63bac5b..5aa994c1e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -211,12 +211,51 @@ fi
AC_CHECK_HEADERS([X11/XF86keysym.h])
+EPIPHANY_FEATURES=
+
+# *********************
+# GObject Introspection
+# *********************
+
+AC_MSG_CHECKING([whether to enable GObject introspection support])
+AC_ARG_ENABLE([introspection],
+ [AS_HELP_STRING([--enable-introspection],[Enable GObject introspection (default: disabled)])],
+ [],[enable_introspection=no])
+AC_MSG_RESULT([$enable_introspection])
+
+G_IR_SCANNER=
+G_IR_COMPILER=
+G_IR_GENERATE=
+GIRDIR=
+GIRTYPELIBDIR=
+
+if test "$enable_introspection" = "yes"; then
+ EPIPHANY_FEATURES="$EPIPHANY_FEATURES introspection"
+
+ GOBJECT_INTROSPECTION_REQUIRED=0.6.2
+ PKG_CHECK_MODULES([INTROSPECTION],[gobject-introspection-1.0 >= $GOBJECT_INTROSPECTION_REQUIRED])
+
+ G_IR_SCANNER="$($PKG_CONFIG --variable=g_ir_scanner gobject-introspection-1.0)"
+ G_IR_COMPILER="$($PKG_CONFIG --variable=g_ir_compiler gobject-introspection-1.0)"
+ G_IR_GENERATE="$($PKG_CONFIG --variable=g_ir_generate gobject-introspection-1.0)"
+ GIRDIR="$($PKG_CONFIG --variable=girdir gobject-introspection-1.0)"
+ GIRTYPELIBDIR="$($PKG_CONFIG --variable=typelibdir gobject-introspection-1.0)"
+
+ AC_DEFINE([ENABLE_INTROSPECTION],[1],[Define to enable GObject introspection support])
+fi
+
+AC_SUBST([G_IR_SCANNER])
+AC_SUBST([G_IR_COMPILER])
+AC_SUBST([G_IR_GENERATE])
+AC_SUBST([GIRDIR])
+AC_SUBST([GIRTYPELIBDIR])
+
+AM_CONDITIONAL([ENABLE_INTROSPECTION],[test "$enable_introspection" = "yes"])
+
# ******
# Python
# ******
-EPIPHANY_FEATURES=
-
AC_MSG_CHECKING([whether Python support is requested])
AC_ARG_ENABLE([python],
@@ -562,6 +601,7 @@ Epiphany was configured with the following options:
Zeroconf bookmarks support : $enable_zeroconf
NetworkManager support : $enable_network_manager
+ GObject introspection : $enable_introspection
Python support : $enable_python
Build tests : $enable_tests
"