aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDiego Escalante Urrelo <diegoe@src.gnome.org>2008-11-30 04:04:31 +0800
committerDiego Escalante Urrelo <diegoe@src.gnome.org>2008-11-30 04:04:31 +0800
commit77e3f89f65528dc69e71d4ee19378836dae7f1f4 (patch)
treeae1c6b0c617e8c5dcb68f7e2537a526f2ad9d2d1 /configure.ac
parentdb47da036dd918084f0f738fa87b1e2ba4dd10a4 (diff)
downloadgsoc2013-epiphany-77e3f89f65528dc69e71d4ee19378836dae7f1f4.tar
gsoc2013-epiphany-77e3f89f65528dc69e71d4ee19378836dae7f1f4.tar.gz
gsoc2013-epiphany-77e3f89f65528dc69e71d4ee19378836dae7f1f4.tar.bz2
gsoc2013-epiphany-77e3f89f65528dc69e71d4ee19378836dae7f1f4.tar.lz
gsoc2013-epiphany-77e3f89f65528dc69e71d4ee19378836dae7f1f4.tar.xz
gsoc2013-epiphany-77e3f89f65528dc69e71d4ee19378836dae7f1f4.tar.zst
gsoc2013-epiphany-77e3f89f65528dc69e71d4ee19378836dae7f1f4.zip
Add --enable-tests to configure
tests/ will be build by default. svn path=/trunk/; revision=8625
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 12 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index b20421293..18fb4744e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -102,7 +102,7 @@ if test "$enable_maintainer_mode" = "yes"; then
fi
GLIB_REQUIRED=2.16.0
-GTK_REQUIRED=2.13.5
+GTK_REQUIRED=2.14.0
LIBXML_REQUIRED=2.6.12
LIBXSLT_REQUIRED=1.1.7
LIBGLADE_REQUIRED=2.3.1
@@ -121,6 +121,16 @@ if test "$have_libnotify" = "yes"; then
AC_DEFINE([HAVE_LIBNOTIFY],[1],[Define if libnotify is available])
fi
+# Tests
+
+AC_MSG_CHECKING([whether to build tests])
+AC_ARG_ENABLE([tests],
+ AS_HELP_STRING([--enable-tests],[Wheter to build tests (default: yes)]),
+ [], [enable_tests=yes])
+AC_MSG_RESULT([$enable_tests])
+
+AM_CONDITIONAL([ENABLE_TESTS],[test "$enable_tests" = "yes"])
+
PKG_CHECK_MODULES([DEPENDENCIES], [
glib-2.0 >= $GLIB_REQUIRED
gmodule-2.0
@@ -554,4 +564,5 @@ Epiphany was configured with the following options:
Zeroconf bookmarks support : $enable_zeroconf
NetworkManager support : $enable_network_manager
Python support : $enable_python
+ Build tests : $enable_tests
"