aboutsummaryrefslogtreecommitdiffstats
path: root/autoarchive/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'autoarchive/Makefile.am')
-rw-r--r--autoarchive/Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/autoarchive/Makefile.am b/autoarchive/Makefile.am
index 0593793f0..b51291385 100644
--- a/autoarchive/Makefile.am
+++ b/autoarchive/Makefile.am
@@ -64,6 +64,20 @@ test_extract_LDADD = \
libautoarchive.la \
$(NULL)
+noinst_PROGRAMS += test-pref
+EXTRA_DIST += test-pref.c
+test_pref_SOURCES = \
+ test-pref.c \
+ $(NULL)
+test_pref_CFLAGS = \
+ $(DEPENDENCIES_CFLAGS) \
+ $(AM_CFLAGS) \
+ $(NULL)
+test_pref_LDADD = \
+ $(DEPENDENCIES_LIBS) \
+ libautoarchive.la \
+ $(NULL)
+
BUILT_SOURCES = \
$(libautoarchive_generated_sources) \
$(NULL)