aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorPeter Williams <peterw@ximian.com>2002-07-18 05:03:19 +0800
committerPeter Williams <peterw@src.gnome.org>2002-07-18 05:03:19 +0800
commit515ebfd45c748cf31e2f45fe9180f97e08051498 (patch)
treed4df60220d5b044b3c084dadbd8d023bae1b4422 /Makefile.am
parent6485e5fcf75cd73418204e444418925134e3bdab (diff)
downloadgsoc2013-evolution-515ebfd45c748cf31e2f45fe9180f97e08051498.tar
gsoc2013-evolution-515ebfd45c748cf31e2f45fe9180f97e08051498.tar.gz
gsoc2013-evolution-515ebfd45c748cf31e2f45fe9180f97e08051498.tar.bz2
gsoc2013-evolution-515ebfd45c748cf31e2f45fe9180f97e08051498.tar.lz
gsoc2013-evolution-515ebfd45c748cf31e2f45fe9180f97e08051498.tar.xz
gsoc2013-evolution-515ebfd45c748cf31e2f45fe9180f97e08051498.tar.zst
gsoc2013-evolution-515ebfd45c748cf31e2f45fe9180f97e08051498.zip
Install libversit.a so that people compiling against the addressbook can
2002-07-09 Peter Williams <peterw@ximian.com> * libversit/Makefile.am (privlib_LIBRARIES): Install libversit.a so that people compiling against the addressbook can do so successfully. * Makefile.am: create our *Conf.sh files and dist them and install them. * configure.in: Define and subst some variables that the Conf.sh file need. 2002-07-08 Peter Williams <peterw@ximian.com> * backend/ebook/Makefile.am: Install libebook-static.la. Also change --all-static to -all-static, which is the right flag. * backend/pas/Makefile.am: Install the PAS headers in $(includedir)/evolution/pas. Install libpas.a 2002-07-08 Peter Williams <peterw@ximian.com> * cal-util/Makefile.am: Install libcal-util-static.la and fix the -all-static flag to make it install statically. * pcs/Makefile.am: Install libpcs.a and its headers. * pcs/cal-backend-util.h: Same sort of include namespacing fix, but for pcs. * pcs/cal.h: * pcs/query.h: * pcs/cal-factory.h: * pcs/cal-backend.h: * pcs/cal-backend-file.h: Same. 2002-07-17 Peter Williams <peterw@ximian.com> * calendar/cal-util/Makefile.am (GTKDOC_LIBS): Because we're using libtool as our LD, we can reference .la's and libtool will DTRT for us. * calendar/cal-client/Makefile.am (GTKDOC_LIBS): Same here. 2002-07-03 Peter Williams <peterw@ximian.com> * Makefile.am: Install libeutil, libeconduit, and libedb3util and their headers. 2002-07-08 Peter Williams <peterw@ximian.com> * Makefile.am: Reference the new libefilterbar.a. 2002-07-12 Peter Williams <peterw@ximian.com> * Makefile.am (INCLUDES): Add -I$(builddir)/libical/src/libical for the generated ical.h (some headers rely on this because they too get installed.) 2002-07-09 Peter Williams <peterw@ximian.com> * e-timezone-dialog/Makefile.am: Add -I$(top_builddir)/libical/src/libical; some headers that we rely on get installed, so they point to the ical.h that gets generated and installed; consequently we need to be able to find the generated ical.h * misc/Makefile.am: Install libemiscwidgets.a and its headers. However, break EFilterBar into a separate libefilterbar.a because we don't want the installed library to depend on libfilter. svn path=/trunk/; revision=17496
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am30
1 files changed, 29 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index df0a66c3fb..d7c2bef2ca 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,6 +1,13 @@
changelogs = \
ChangeLog
+confexecdir = $(libdir)
+confexec_DATA = \
+ camelConf.sh \
+ evolution_shellConf.sh \
+ evolution_addressbookConf.sh \
+ evolution_calendarConf.sh
+
EXTRA_DIST = \
AUTHORS \
$(changelogs) \
@@ -11,7 +18,8 @@ EXTRA_DIST = \
NEWS \
xml-i18n-merge.in \
xml-i18n-update.in \
- xml-i18n-extract.in
+ xml-i18n-extract.in \
+ $(confexec_DATA:.sh=.sh.in)
SUBDIRS = \
intl \
@@ -43,3 +51,23 @@ SUBDIRS = \
po \
omf-install
+%Conf.sh: %Conf.sh.in Makefile
+ sed -e 's?\@EVOLUTION_LIBDIR\@?$(EVOLUTION_LIBDIR)?g' \
+ -e 's?\@EVOLUTION_DATADIR\@?$(EVOLUTION_DATADIR)?g' \
+ -e 's?\@EVOLUTION_INCLUDEDIR\@?$(EVOLUTION_INCLUDEDIR)?g' \
+ -e 's?\@CAMEL_INCLUDEDIR\@?$(CAMEL_INCLUDEDIR)?g' \
+ -e 's?\@VERSION\@?$(VERSION)?g' \
+ -e 's?\@privlibdir\@?$(privlibdir)?g' \
+ -e 's?\@SHELL_LIBS\@?$(SHELL_LIBS)?g' \
+ -e 's?\@SHELL_CFLAGS\@?$(SHELL_CFLAGS)?g' \
+ -e 's?\@CAMEL_LIBS\@?$(CAMEL_LIBS)?g' \
+ -e 's?\@CAMEL_CFLAGS\@?$(CAMEL_CFLAGS)?g' \
+ -e 's?\@LDAP_LIBS\@?$(LDAP_LIBS)?g' \
+ -e 's?\@LDAP_CFLAGS\@?$(LDAP_CFLAGS)?g' \
+ -e 's?\@EVOLUTION_ADDRESSBOOK_LIBS\@?$(EVOLUTION_ADDRESSBOOK_LIBS)?g' \
+ -e 's?\@EVOLUTION_ADDRESSBOOK_CFLAGS\@?$(EVOLUTION_ADDRESSBOOK_CFLAGS)?g' \
+ -e 's?\@EVOLUTION_CALENDAR_LIBS\@?$(EVOLUTION_CALENDAR_LIBS)?g' \
+ -e 's?\@EVOLUTION_CALENDAR_CFLAGS\@?$(EVOLUTION_CALENDAR_CFLAGS)?g' \
+ < $(srcdir)/$< > $@.tmp \
+ && mv $@.tmp $@
+