aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMatthew Barnes <mbarnes@redhat.com>2010-02-03 02:19:40 +0800
committerMatthew Barnes <mbarnes@redhat.com>2010-02-03 07:27:04 +0800
commit0727097ac13ad746184ba0580247bff70cefbb68 (patch)
tree3374a68bb7d9dd80775af3d39994cc1ec5b4e444 /configure.ac
parentdce48c142cae497ffe518b4a4427df6fac46c398 (diff)
downloadgsoc2013-evolution-0727097ac13ad746184ba0580247bff70cefbb68.tar
gsoc2013-evolution-0727097ac13ad746184ba0580247bff70cefbb68.tar.gz
gsoc2013-evolution-0727097ac13ad746184ba0580247bff70cefbb68.tar.bz2
gsoc2013-evolution-0727097ac13ad746184ba0580247bff70cefbb68.tar.lz
gsoc2013-evolution-0727097ac13ad746184ba0580247bff70cefbb68.tar.xz
gsoc2013-evolution-0727097ac13ad746184ba0580247bff70cefbb68.tar.zst
gsoc2013-evolution-0727097ac13ad746184ba0580247bff70cefbb68.zip
Clarify a configure.ac comment.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 7 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index b034b76012..643d691a11 100644
--- a/configure.ac
+++ b/configure.ac
@@ -84,17 +84,19 @@ AS_COMPILER_FLAGS(WARNING_FLAGS,
AC_SUBST(WARNING_FLAGS)
dnl Other useful compiler warnings for test builds only.
-dnl These may produce warnings we have no control over.
+dnl These may produce warnings we have no control over,
+dnl or false positives we don't always want to see.
+dnl
dnl -Wmissing-format-attribute
dnl -Wshadow
dnl -Wformat-nonliteral
+dnl -Wstrict-aliasing=2
-dnl GCC 4.4 got more aggressive in it's aliasing optimizations, changing
+dnl GCC 4.4 got more aggressive in its aliasing optimizations, changing
dnl behavior that -- according to the C99 standard -- is supposed to be
dnl undefined. We may still have aliasing abuses lying around that rely
-dnl on GCC's previous "undefined" behavior but are hidden by type casts,
-dnl so disable the strict-aliasing optimzation until GCC (or even LLVM)
-dnl learns how to detect them and warn us about it.
+dnl on GCC's previous "undefined" behavior, so disable strict-aliasing
+dnl optimzation until we can find and fix all the abuses.
dnl XXX This really belongs in AM_CFLAGS.
AM_CPPFLAGS="$WARNING_FLAGS -fno-strict-aliasing"
AC_SUBST(AM_CPPFLAGS)