aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMatthew Barnes <mbarnes@redhat.com>2013-07-08 11:51:24 +0800
committerMatthew Barnes <mbarnes@redhat.com>2013-07-08 12:08:54 +0800
commit3b8a9ed601e38a6a0d94fa661fccd4a5000f4b0e (patch)
tree5ce2ab50bdf40b3b9a0204083bc5d8b330254e4d /configure.ac
parent5c866713c795795ef46cc90ed95ed7de98152971 (diff)
downloadgsoc2013-evolution-3b8a9ed601e38a6a0d94fa661fccd4a5000f4b0e.tar
gsoc2013-evolution-3b8a9ed601e38a6a0d94fa661fccd4a5000f4b0e.tar.gz
gsoc2013-evolution-3b8a9ed601e38a6a0d94fa661fccd4a5000f4b0e.tar.bz2
gsoc2013-evolution-3b8a9ed601e38a6a0d94fa661fccd4a5000f4b0e.tar.lz
gsoc2013-evolution-3b8a9ed601e38a6a0d94fa661fccd4a5000f4b0e.tar.xz
gsoc2013-evolution-3b8a9ed601e38a6a0d94fa661fccd4a5000f4b0e.tar.zst
gsoc2013-evolution-3b8a9ed601e38a6a0d94fa661fccd4a5000f4b0e.zip
Bug 703490 - Stop invoking spamc, just use spamassassin
SpamAssassin is clearly not intended for use by mail clients, as evidenced by the number of backflips Evolution's SA module still has to do just to detect the presence and nature of a running spamd (a problem which D-Bus solved a decade ago), and recent SA developer comments. In lieu of removing SA support entirely, remove all the crazy GSettings that are (thankfully) not exposed in the UI and relegate Evolution's SA integration to only the most basic usage (spamassassin / sa-learn). Users are better off with Bogofilter anyway. Leave SpamAssassin for mail servers.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 0 insertions, 18 deletions
diff --git a/configure.ac b/configure.ac
index aba8b51dde..aa032f246c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1023,24 +1023,6 @@ if test "x$enable_spamassassin" = "xyes"; then
SA_LEARN_COMMAND, "$SA_LEARN",
[SpamAssassin spam training program])
- dnl The spamc/spamd programs are optional.
- AC_ARG_VAR([SPAMC], [SpamAssassin client])
- AC_PATH_PROG([SPAMC], [spamc])
- if test "x$SPAMC" != "x"; then
- AC_DEFINE_UNQUOTED(
- SPAMC_COMMAND, "$SPAMC",
- [SpamAssassin client])
- fi
-
- dnl The spamc/spamd programs are optional.
- AC_ARG_VAR([SPAMD], [SpamAssassin daemon])
- AC_PATH_PROG([SPAMD], [spamd])
- if test "x$SPAMD" != "x"; then
- AC_DEFINE_UNQUOTED(
- SPAMD_COMMAND, "$SPAMD",
- [SpamAssassin daemon])
- fi
-
msg_spamassassin="$msg_spamassassin ($SPAMASSASSIN)"
fi
AM_CONDITIONAL([ENABLE_SPAMASSASSIN], [test "x$enable_spamassassin" = "xyes"])