aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorRadek Doulik <rodo@src.gnome.org>2004-10-26 01:48:59 +0800
committerRadek Doulik <rodo@src.gnome.org>2004-10-26 01:48:59 +0800
commit58519e7cec5c94bc0c2064c260718565c0c6e489 (patch)
tree32225621419b657b7637e4ede71356d5a61d7ed4 /configure.in
parent0e92e94b3800d682a3a74da8cef3d928b8d891f2 (diff)
downloadgsoc2013-evolution-58519e7cec5c94bc0c2064c260718565c0c6e489.tar
gsoc2013-evolution-58519e7cec5c94bc0c2064c260718565c0c6e489.tar.gz
gsoc2013-evolution-58519e7cec5c94bc0c2064c260718565c0c6e489.tar.bz2
gsoc2013-evolution-58519e7cec5c94bc0c2064c260718565c0c6e489.tar.lz
gsoc2013-evolution-58519e7cec5c94bc0c2064c260718565c0c6e489.tar.xz
gsoc2013-evolution-58519e7cec5c94bc0c2064c260718565c0c6e489.tar.zst
gsoc2013-evolution-58519e7cec5c94bc0c2064c260718565c0c6e489.zip
if gstreamer is not available, remove audio-inline plugin from the
plugins list svn path=/trunk/; revision=27722
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in20
1 files changed, 13 insertions, 7 deletions
diff --git a/configure.in b/configure.in
index 173337f183..e11d543d1a 100644
--- a/configure.in
+++ b/configure.in
@@ -1359,13 +1359,19 @@ AC_SUBST(plugins_all)
if echo ${plugins_enabled} | grep -q "audio-inline"
then
-
- dnl *********************
- dnl gstreamer
- dnl *********************
- PKG_CHECK_MODULES(GSTREAMER, gstreamer-0.8)
- AC_SUBST(GSTREAMER_CFLAGS)
- AC_SUBST(GSTREAMER_LIBS)
+ if ${PKG_CONFIG} --exists gstreamer-0.8
+ then
+ dnl *********************
+ dnl gstreamer
+ dnl *********************
+ PKG_CHECK_MODULES(GSTREAMER, gstreamer-0.8)
+ AC_SUBST(GSTREAMER_CFLAGS)
+ AC_SUBST(GSTREAMER_LIBS)
+ else
+ plugins_enabled=`echo $plugins_enabled | sed -e "s/audio-inline//g"`
+ echo "warning: gstreamer was not found, audio-inline pluging will not be built."
+ echo "you are probably missing gstreamer-devel package."
+ fi
fi
##################################################