aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorJames Henstridge <james@jamesh.id.au>2005-04-20 11:42:13 +0800
committerJames Henstridge <jamesh@src.gnome.org>2005-04-20 11:42:13 +0800
commit6faf15be961da95ae18822e7c087000f35da9a17 (patch)
tree2e883a016def1c8de09379af2b6f8c54b70a3fc2 /configure.in
parenteee4b4eb14748761015e8db96c539a23c859acf7 (diff)
downloadgsoc2013-evolution-6faf15be961da95ae18822e7c087000f35da9a17.tar
gsoc2013-evolution-6faf15be961da95ae18822e7c087000f35da9a17.tar.gz
gsoc2013-evolution-6faf15be961da95ae18822e7c087000f35da9a17.tar.bz2
gsoc2013-evolution-6faf15be961da95ae18822e7c087000f35da9a17.tar.lz
gsoc2013-evolution-6faf15be961da95ae18822e7c087000f35da9a17.tar.xz
gsoc2013-evolution-6faf15be961da95ae18822e7c087000f35da9a17.tar.zst
gsoc2013-evolution-6faf15be961da95ae18822e7c087000f35da9a17.zip
fix up macro so that it doesn't trigger configure failures with newer
2005-04-20 James Henstridge <james@jamesh.id.au> * configure.in (EVO_SET_COMPILE_FLAGS): fix up macro so that it doesn't trigger configure failures with newer versions of pkg-config. Fixes bug #300436. svn path=/trunk/; revision=29218
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in12
1 files changed, 5 insertions, 7 deletions
diff --git a/configure.in b/configure.in
index f11b4c0e2a..52b16c9480 100644
--- a/configure.in
+++ b/configure.in
@@ -1079,13 +1079,11 @@ AC_MSG_RESULT($IDL_INCLUDES)
AC_SUBST(IDL_INCLUDES)
dnl Utility macro to set compiler flags for a specific lib.
-AC_DEFUN(EVO_SET_COMPILE_FLAGS, [
- deps="$2"
- extra_cflags="$3"
- extra_libs="$4"
- PKG_CHECK_MODULES(EVOLUTION, $deps)
- $1_CFLAGS="$EVOLUTION_CFLAGS \$(WERROR) $extra_cflags"
- $1_LIBS="$EVOLUTION_LIBS $extra_libs"
+dnl EVO_SET_COMPILE_FLAGS(VAR-PREFIX, DEPS, EXTRA-CFLAGS, EXTRA-LIBS)
+AC_DEFUN([EVO_SET_COMPILE_FLAGS], [
+ PKG_CHECK_MODULES([$1], [$2])
+ $1_CFLAGS="[$]$1_CFLAGS \$(WERROR) $3"
+ $1_LIBS="[$]$1_LIBS $4"
])
dnl enable USE_GTKFILECHOOSER if gtk version is > 2.4.0