aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorFederico Mena Quintero <federico@helixcode.com>2000-07-18 05:09:46 +0800
committerFederico Mena Quintero <federico@src.gnome.org>2000-07-18 05:09:46 +0800
commitaf439c73e3770527174a54c2c28ab5e2e3615126 (patch)
tree4824a1a3caa1234a9f2669cc6ecb014203f640ea /configure.in
parente38c9ea0ed0f14ce563d355a0cea24460df26363 (diff)
downloadgsoc2013-evolution-af439c73e3770527174a54c2c28ab5e2e3615126.tar
gsoc2013-evolution-af439c73e3770527174a54c2c28ab5e2e3615126.tar.gz
gsoc2013-evolution-af439c73e3770527174a54c2c28ab5e2e3615126.tar.bz2
gsoc2013-evolution-af439c73e3770527174a54c2c28ab5e2e3615126.tar.lz
gsoc2013-evolution-af439c73e3770527174a54c2c28ab5e2e3615126.tar.xz
gsoc2013-evolution-af439c73e3770527174a54c2c28ab5e2e3615126.tar.zst
gsoc2013-evolution-af439c73e3770527174a54c2c28ab5e2e3615126.zip
Added the doc/devel Makefiles. (EVOLUTION_DIR): Substitute EVOLUTION_DIR
2000-07-17 Federico Mena Quintero <federico@helixcode.com> * configure.in (AC_OUTPUT): Added the doc/devel Makefiles. (EVOLUTION_DIR): Substitute EVOLUTION_DIR for the top_srcdir. Added checks for gtk-doc. svn path=/trunk/; revision=4192
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in30
1 files changed, 30 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index da4f2523e8..26f9d571f2 100644
--- a/configure.in
+++ b/configure.in
@@ -462,11 +462,38 @@ AC_SUBST(KRB4_LDFLAGS)
dnl ******************************
+dnl gtk-doc
+dnl ******************************
+
+AC_CHECK_PROG(GTKDOC, gtkdoc-mkdb, true, false)
+AM_CONDITIONAL(HAVE_GTK_DOC, $GTKDOC)
+AC_SUBST(HAVE_GTK_DOC)
+
+dnl Let people disable the gtk-doc stuff.
+AC_ARG_ENABLE(gtk-doc, [ --enable-gtk-doc Use gtk-doc to build documentation [default=auto]], enable_gtk_doc="$enableval", enable_gtk_doc=auto)
+
+if test x$enable_gtk_doc = xauto ; then
+ if test x$GTKDOC = xtrue ; then
+ enable_gtk_doc=yes
+ else
+ enable_gtk_doc=no
+ fi
+fi
+
+dnl NOTE: We need to use a separate automake conditional for this
+dnl to make this work with the tarballs.
+AM_CONDITIONAL(ENABLE_GTK_DOC, test x$enable_gtk_doc = xyes)
+
+
+dnl ******************************
dnl Makefiles
dnl ******************************
AC_CONFIG_SUBDIRS(libical)
+EVOLUTION_DIR=`(cd srcdir; pwd)`
+AC_SUBST(EVOLUTION_DIR)
+
AC_OUTPUT([
Makefile
evolution.spec
@@ -533,4 +560,7 @@ default_user/local/Trash/Makefile
tools/Makefile
doc/Makefile
doc/C/Makefile
+doc/devel/Makefile
+doc/devel/calendar/Makefile
+doc/devel/calendar/cal-client/Makefile
])