aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorJeffrey Stedfast <fejj@ximian.com>2001-03-15 06:02:23 +0800
committerJeffrey Stedfast <fejj@src.gnome.org>2001-03-15 06:02:23 +0800
commitf19bb8e86d1b25ef18a4dc060334498b90a01fb9 (patch)
treeee041daa7d29d97e12363a66244b76c964b20e09 /configure.in
parent174adfa471581f0a322b4e381d9671b2b50ac9d4 (diff)
downloadgsoc2013-evolution-f19bb8e86d1b25ef18a4dc060334498b90a01fb9.tar
gsoc2013-evolution-f19bb8e86d1b25ef18a4dc060334498b90a01fb9.tar.gz
gsoc2013-evolution-f19bb8e86d1b25ef18a4dc060334498b90a01fb9.tar.bz2
gsoc2013-evolution-f19bb8e86d1b25ef18a4dc060334498b90a01fb9.tar.lz
gsoc2013-evolution-f19bb8e86d1b25ef18a4dc060334498b90a01fb9.tar.xz
gsoc2013-evolution-f19bb8e86d1b25ef18a4dc060334498b90a01fb9.tar.zst
gsoc2013-evolution-f19bb8e86d1b25ef18a4dc060334498b90a01fb9.zip
Updated to AC_SUBST the NSPR/NSS flags.
2001-03-12 Jeffrey Stedfast <fejj@ximian.com> * configure.in: Updated to AC_SUBST the NSPR/NSS flags. svn path=/trunk/; revision=8712
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in14
1 files changed, 12 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index c8c62ea26d..cd06730a07 100644
--- a/configure.in
+++ b/configure.in
@@ -600,7 +600,7 @@ dnl = Camel (SSL) and Evolution (S/MIME).
dnl =
dnl = The Evolution security extensions are only built if these libraries are found
dnl ====================================
-with_nspr_includes=/usr/include
+with_nspr_includes=/usr/include/mozilla
AC_ARG_WITH(nspr-includes, [ --with-nspr-includes=PREFIX Location of Mozilla nspr4 libs.])
have_nspr_includes="no"
if test "x${with_nspr_includes}" != "xno"; then
@@ -609,7 +609,7 @@ if test "x${with_nspr_includes}" != "xno"; then
AC_MSG_CHECKING(for Mozilla nspr4 includes in $with_nspr_includes/mozilla)
AC_MSG_RESULT("")
CFLAGS="$CFLAGS -I$with_nspr_includes"
- AC_CHECK_HEADERS(mozilla/prinit.h mozilla/prio.h, [ moz_nspr_includes="yes" ])
+ AC_CHECK_HEADERS(prinit.h prio.h, [ moz_nspr_includes="yes" ])
CFLAGS="$CFLAGS_save"
if test "x{$moz_nspr_includes}" != "xno"; then
@@ -640,6 +640,8 @@ if test "x${with_nspr_libs}" != "xno" -a "x${have_nspr_includes}" != "xno"; then
if test "x$moz_nspr_libs" != "xno"; then
have_nspr_libs="yes"
NSPR_LDFLAGS="-L$with_nspr_libs $nsprlibs"
+ else
+ NSPR_CLFAGS=""
fi
else
AC_MSG_CHECKING(for Mozilla nspr4 libraries)
@@ -664,12 +666,20 @@ if test "x${with_nss}" != "xno" -a "x${have_nspr_libs}" != "xno"; then
msg_nss="yes"
NSS_CFLAGS="-I$with_nss/include"
NSS_LDFLAGS="-L$with_nss/lib $nsslibs"
+ else
+ NSPR_CFLAGS=""
+ NSPR_LDFLAGS=""
fi
else
AC_MSG_CHECKING(for Mozilla nss libraries)
AC_MSG_RESULT(no)
fi
+AC_SUBST(NSPR_CFLAGS)
+AC_SUBST(NSPR_LDFLAGS)
+AC_SUBST(NSS_CFLAGS)
+AC_SUBST(NSS_LDFLAGS)
+
dnl ====================================
dnl = End mozilla hacks
dnl ====================================