aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am19
1 files changed, 18 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index df0a66c3fb..74e38efa3e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -21,6 +21,7 @@ SUBDIRS = \
libical \
widgets \
shell \
+ libibex \
camel \
filter \
libversit \
@@ -33,7 +34,6 @@ SUBDIRS = \
importers \
my-evolution \
art \
- sounds \
ui \
default_user \
views \
@@ -43,3 +43,20 @@ SUBDIRS = \
po \
omf-install
+# CDE Stuff
+
+if HAVE_DTAPPINTEGRATE
+
+# This installs Evolution into the Application Manager on CDE
+dtappintegrate:
+ ( cd data && make dtappintegrate )
+
+# ...And this uninstalls it
+dtappunintegrate:
+ ( cd data ; make dtappunintegrate )
+
+# Install/uninstall for CDE
+cde-install: install dtappintegrate
+cde-uninstall: dtappunintegrate uninstall
+
+endif