aboutsummaryrefslogtreecommitdiffstats
path: root/a11y/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'a11y/Makefile.am')
-rw-r--r--a11y/Makefile.am40
1 files changed, 9 insertions, 31 deletions
diff --git a/a11y/Makefile.am b/a11y/Makefile.am
index 0edcb07bca..c98e486e7f 100644
--- a/a11y/Makefile.am
+++ b/a11y/Makefile.am
@@ -1,38 +1,16 @@
-# Somewhat odd looking to have "." in SUBDIRS, but apparently it works?
-SUBDIRS = e-text e-table . calendar widgets addressbook
-
-if OS_WIN32
-WIN32_BOOTSTRAP_LIBS = \
- $(top_builddir)/win32/libemiscwidgets.la \
- $(top_builddir)/win32/libetable.la \
- $(top_builddir)/win32/libetext.la
-endif
+SUBDIRS = . calendar widgets addressbook
# for debug
#A11Y_CFLAGS += -pedantic -ansi -DACC_DEBUG -Werror
-privsolib_LTLIBRARIES = libevolution-a11y.la
-
-INCLUDES = \
- $(A11Y_CFLAGS)
-
-libevolution_a11y_la_SOURCES = \
- ea-factory.h \
- ea-cell-table.h \
- ea-cell-table.c \
- gal-a11y-util.c
-
-libevolution_a11yincludedir = $(privincludedir)/a11y
+privlib_LTLIBRARIES = libevolution-a11y.la
-libevolution_a11yinclude_HEADERS = \
- gal-a11y-util.h \
- gal-a11y-factory.h
+INCLUDES = \
+ -I$(top_srcdir)/a11y \
+ $(A11Y_CFLAGS)
-libevolution_a11y_la_LDFLAGS = $(NO_UNDEFINED)
+libevolution_a11y_la_SOURCES = \
+ ea-factory.h \
+ ea-cell-table.h \
+ ea-cell-table.c
-libevolution_a11y_la_LIBADD = \
- $(WIN32_BOOTSTRAP_LIBS) \
- e-text/libgal-a11y-etext.la \
- e-table/libgal-a11y-etable.la \
- $(top_builddir)/e-util/libeutil.la \
- $(EXTRA_GNOME_LIBS)