aboutsummaryrefslogtreecommitdiffstats
path: root/camel/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'camel/Makefile.am')
-rw-r--r--camel/Makefile.am46
1 files changed, 20 insertions, 26 deletions
diff --git a/camel/Makefile.am b/camel/Makefile.am
index 7055630273..c79045cdfe 100644
--- a/camel/Makefile.am
+++ b/camel/Makefile.am
@@ -1,22 +1,20 @@
## Process this file with automake to produce Makefile.in
-SUBDIRS = . providers tests
+SUBDIRS = providers tests
-libcamelincludedir = $(privincludedir)/camel
+libcamelincludedir = $(includedir)/camel
-camellibexecdir = $(privlibexecdir)/camel
-camellibexec_PROGRAMS = camel-lock-helper camel-index-control
+sbin_PROGRAMS = camel-lock-helper camel-index-control
-privlib_LTLIBRARIES = libcamel.la
+lib_LTLIBRARIES = libcamel.la
noinst_LTLIBRARIES = libcamel-static.la
INCLUDES = -I.. -I$(srcdir)/.. \
-I$(top_srcdir)/intl \
-I$(top_srcdir)/e-util \
- -DCAMEL_LIBEXECDIR=\""$(camellibexecdir)"\" \
+ -DCAMEL_SBINDIR=\""$(sbindir)"\" \
-DCAMEL_PROVIDERDIR=\""$(camel_providerdir)"\" \
-DG_LOG_DOMAIN=\"camel\" \
- -DG_DISABLE_DEPRECATED \
$(CAMEL_CFLAGS)
libcamel_la_SOURCES = \
@@ -55,9 +53,9 @@ libcamel_la_SOURCES = \
camel-mime-filter-bestenc.c \
camel-mime-filter-basic.c \
camel-mime-filter-charset.c \
+ camel-mime-filter-chomp.c \
camel-mime-filter-canon.c \
camel-mime-filter-crlf.c \
- camel-mime-filter-enriched.c \
camel-mime-filter-from.c \
camel-mime-filter-html.c \
camel-mime-filter-tohtml.c \
@@ -112,12 +110,13 @@ libcamel_la_SOURCES = \
camel-transport.c \
camel-uid-cache.c \
camel-url.c \
- camel-url-scanner.c \
camel-utf8.c \
camel-vee-folder.c \
camel-vee-store.c \
camel-vtrash-folder.c \
camel.c \
+ gstring-util.c \
+ hash-table-utils.c \
string-utils.c
libcamelinclude_HEADERS = \
@@ -150,16 +149,15 @@ libcamelinclude_HEADERS = \
camel-http-stream.h \
camel-index.h \
camel-internet-address.h \
- camel-i18n.h \
camel-lock.h \
camel-lock-client.h \
camel-medium.h \
camel-mime-filter-bestenc.h \
camel-mime-filter-basic.h \
camel-mime-filter-charset.h \
+ camel-mime-filter-chomp.h \
camel-mime-filter-canon.h \
camel-mime-filter-crlf.h \
- camel-mime-filter-enriched.h \
camel-mime-filter-from.h \
camel-mime-filter-html.h \
camel-mime-filter-tohtml.h \
@@ -213,15 +211,16 @@ libcamelinclude_HEADERS = \
camel-types.h \
camel-uid-cache.h \
camel-url.h \
- camel-url-scanner.h \
camel-utf8.h \
camel-vee-folder.h \
camel-vee-store.h \
camel-vtrash-folder.h \
camel.h \
+ gstring-util.h \
+ hash-table-utils.h \
string-utils.h
-libcamel_la_LDFLAGS = -version-info 0:0:0
+libcamel_la_LDFLAGS = -version-info 0:0:0 -rpath $(libdir)
libcamel_la_LIBADD = \
$(top_builddir)/e-util/libeutil.la \
@@ -237,24 +236,19 @@ camel_lock_helper_SOURCES = \
camel-lock.c \
camel-lock.h
-# NOTE: This needs to be cleaned up, it shouldn't link with all this crap,
-# because it might be setuid.
-camel_lock_helper_LDADD = \
- $(libcamel_la_LIBADD)
-
camel_index_control_SOURCES = \
camel-index-control.c
camel_index_control_LDADD = \
$(libcamel_la_LIBADD) \
- libcamel.la
-# $(EVOLUTION_MAIL_LIBS)
+ libcamel.la \
+ $(EVOLUTION_MAIL_LIBS)
install-exec-hook:
@if test -n "$(CAMEL_LOCK_HELPER_USER)"; then \
if test `whoami` = root ; then \
- chown $(CAMEL_LOCK_HELPER_USER) $(DESTDIR)$(camellibexecdir)/camel-lock-helper ; \
- chmod u+s $(DESTDIR)$(camellibexecdir)/camel-lock-helper ; \
+ chown $(CAMEL_LOCK_HELPER_USER) $(DESTDIR)$(sbindir)/camel-lock-helper ; \
+ chmod u+s $(DESTDIR)$(sbindir)/camel-lock-helper ; \
else \
echo '*** WARNING ***' ; \
echo "Camel will not be able to open mbox files until you perform the following steps:" ; \
@@ -268,14 +262,14 @@ install-exec-hook:
fi
@if test -n "$(CAMEL_LOCK_HELPER_GROUP)"; then \
if test `whoami` = root ; then \
- chgrp $(CAMEL_LOCK_HELPER_GROUP) $(DESTDIR)$(camellibexecdir)/camel-lock-helper ; \
- chmod g+s $(DESTDIR)$(camellibexecdir)/camel-lock-helper ; \
+ chgrp $(CAMEL_LOCK_HELPER_GROUP) $(DESTDIR)$(sbindir)/camel-lock-helper ; \
+ chmod g+s $(DESTDIR)$(sbindir)/camel-lock-helper ; \
else \
echo '*** WARNING ***' ; \
echo "Camel will not be able to open mbox files until you perform the following steps:" ; \
echo " 1. Become root" ; \
- echo " 2. chgrp $(CAMEL_LOCK_HELPER_GROUP) $(DESTDIR)$(camellibexecdir)/camel-lock-helper" ; \
- echo " 3. chmod g+s $(DESTDIR)$(camellibexecdir)/camel-lock-helper" ; \
+ echo " 2. chgrp $(CAMEL_LOCK_HELPER_GROUP) $(DESTDIR)$(sbindir)/camel-lock-helper" ; \
+ echo " 3. chmod g+s $(DESTDIR)$(sbindir)/camel-lock-helper" ; \
echo '*** WARNING ***' ; \
fi \
else \