aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in91
1 files changed, 8 insertions, 83 deletions
diff --git a/configure.in b/configure.in
index 1c07b471b1..833707be77 100644
--- a/configure.in
+++ b/configure.in
@@ -3,16 +3,16 @@ AC_INIT(camel)
AM_CONFIG_HEADER(config.h)
EVOLUTION_MAJOR_VERSION=1
-EVOLUTION_MINOR_VERSION=1
-EVOLUTION_MICRO_VERSION=0
+EVOLUTION_MINOR_VERSION=0
+EVOLUTION_MICRO_VERSION=2
EVOLUTION_NANO_VERSION=99
-VERSION=$EVOLUTION_MAJOR_VERSION.$EVOLUTION_MINOR_VERSION.$EVOLUTION_MICRO_VERSION.$EVOLUTION_NANO_VERSION
+VERSION=$EVOLUTION_MAJOR_VERSION.$EVOLUTION_MINOR_VERSION.$EVOLUTION_MICRO_VERSION
PACKAGE=evolution
AM_INIT_AUTOMAKE($PACKAGE, $VERSION)
AC_SUBST(VERSION)
-AC_DEFINE_UNQUOTED(VERSION_COMMENT, "(Preview Release)")
+AC_DEFINE_UNQUOTED(VERSION_COMMENT, "")
AC_DEFUN(EVO_CHECK_LIB, [
dispname="$1"
@@ -113,9 +113,8 @@ GNOME_INIT()
GNOME_COMPILE_WARNINGS
GNOME_X_CHECKS
EVO_CHECK_LIB(gnome-libs, gnome, 1.2.9)
-AC_CHECK_HEADERS(alloca.h)
-ALL_LINGUAS="az bg ca da de el en_AU en_GB es eu fi fr ga gl hu it ja ko lt lv nl nn no pl pt pt_BR ro ru sk sl sv tr uk zh_CN zh_TW"
+ALL_LINGUAS="az bg ca da de el en_AU en_GB es fi fr ga gl hu it ja ko lt lv nl nn no pl pt pt_BR ro ru sk sl sv tr uk zh_CN zh_TW"
AM_GNOME_GETTEXT
localedir='$(prefix)/$(DATADIRNAME)/locale'
AC_SUBST(localedir)
@@ -579,9 +578,8 @@ EVO_CHECK_LIB(GNOME-VFS, vfs, 1.0)
EVO_CHECK_LIB(libxml, xml, 1.8.10, 2.0)
EVO_CHECK_LIB(bonobo-conf, bonobo_conf, 0.11)
-EVO_CHECK_LIB(GAL, gal, 0.18.1)
-EVO_CHECK_LIB(GtkHTML, gtkhtml, 1.0)
-EVO_CHECK_LIB(Libsoup, soup, 0.6)
+EVO_CHECK_LIB(GAL, gal, 0.19)
+EVO_CHECK_LIB(GtkHTML, gtkhtml, 1.0.1)
dnl *************************
dnl CFLAGS and LIBS and stuff
@@ -657,11 +655,6 @@ MAILER_LIBS="`gnome-config --libs gtkhtml libglade gdk_pixbuf gnomecanvaspixbuf
AC_SUBST(MAILER_CFLAGS)
AC_SUBST(MAILER_LIBS)
-SOUP_CFLAGS="`gnome-config --cflags soup`"
-SOUP_LIBS="`gnome-config --libs soup`"
-AC_SUBST(SOUP_CFLAGS)
-AC_SUBST(SOUP_LIBS)
-
dnl ******************************
dnl Pilot checking
dnl ******************************
@@ -776,8 +769,7 @@ if test x${with_krb4:=no} != xno; then
msg_krb4=yes
if test -f "$with_krb4/include/krb.h" -o -f "$with_krb4/include/port-sockets.h"; then
KRB4_CFLAGS="-I$with_krb4/include"
- fi
- if test -d "$with_krb4/include/kerberosIV"; then
+ else
KRB4_CFLAGS="-I$with_krb4/include/kerberosIV"
fi
KRB4_LDFLAGS="-L$with_krb4/lib $ac_cv_lib_kerberos4"
@@ -939,73 +931,6 @@ AC_SUBST(NSPR_LDFLAGS)
AC_SUBST(NSS_CFLAGS)
AC_SUBST(NSS_LDFLAGS)
-dnl ******************************
-dnl OpenSSL
-dnl ******************************
-
-if test "$msg_ssl" = "no"; then
- AC_ARG_WITH(openssl-includes, [ --with-openssl-includes=PREFIX Location of OpenSSL includes.],
- with_openssl_includes="$withval", with_openssl_includes="/usr/include")
- have_openssl_includes="no"
- if test "x${with_openssl_includes}" != "xno"; then
- CPPFLAGS_save="$CPPFLAGS"
-
- AC_MSG_CHECKING(for OpenSSL includes)
- AC_MSG_RESULT("")
-
- CPPFLAGS="$CPPFLAGS -I$with_openssl_includes"
- AC_CHECK_HEADERS(openssl/ssl.h openssl/x509.h, [ openssl_includes="yes" ])
- CPPFLAGS="$CPPFLAGS_save"
-
- if test "x{$openssl_includes}" != "xno" -a "x{$openssl_includes}" != "x"; then
- have_openssl_includes="yes"
- OPENSSL_CFLAGS="-I$with_openssl_includes"
- else
- OPENSSL_CFLAGS=""
- fi
- else
- AC_MSG_CHECKING(for OpenSSL includes)
- AC_MSG_RESULT(no)
- fi
-
- AC_ARG_WITH(openssl-libs, [ --with-openssl-libs=PREFIX Location of OpenSSL libs.],
- with_openssl_libs="$withval")
- if test "x${with_openssl_libs}" != "xno" -a "x${have_openssl_includes}" != "xno"; then
- LDFLAGS_save="$LDFLAGS"
-
- case $with_openssl_libs in
- ""|-L*) ;;
- *) with_openssl_libs="-L$with_openssl_libs" ;;
- esac
-
- AC_CHECK_LIB(dl, dlopen, DL_LDFLAGS="-ldl", DL_LDFLAGS="")
- AC_CACHE_CHECK([for OpenSSL libraries], openssl_libs,
- [
- LDFLAGS="$LDFLAGS $with_openssl_libs -lssl -lcrypto $DL_LDFLAGS"
- AC_TRY_LINK_FUNC(SSL_read, openssl_libs="yes", openssl_libs="no")
- LDFLAGS="$LDFLAGS_save"
- ])
- if test "x${openssl_libs}" != "xno"; then
- AC_DEFINE(HAVE_OPENSSL)
- AC_DEFINE(HAVE_SSL)
- msg_ssl="yes (OpenSSL)"
- OPENSSL_LDFLAGS="$with_openssl_libs -lssl -lcrypto $DL_LDFLAGS"
- else
- OPENSSL_CFLAGS=""
- OPENSSL_LDFLAGS=""
- fi
- else
- AC_MSG_CHECKING(for OpenSSL libraries)
- AC_MSG_RESULT(no)
- fi
-else
- OPENSSL_CFLAGS=""
- OPENSSL_LDFLAGS=""
-fi
-
-AC_SUBST(OPENSSL_CFLAGS)
-AC_SUBST(OPENSSL_LDFLAGS)
-
##################################################
# Check for gtk-doc.
##################################################