aboutsummaryrefslogtreecommitdiffstats
path: root/shell/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'shell/Makefile.am')
-rw-r--r--shell/Makefile.am84
1 files changed, 41 insertions, 43 deletions
diff --git a/shell/Makefile.am b/shell/Makefile.am
index ea885f7233..32b778ae6d 100644
--- a/shell/Makefile.am
+++ b/shell/Makefile.am
@@ -1,23 +1,25 @@
SUBDIRS = glade importer
-INCLUDES = -O \
- -I$(top_srcdir)/widgets \
- -I$(top_srcdir)/widgets/misc \
- -I$(top_srcdir)/libical/src/libical \
- -I$(top_srcdir) \
- -DEVOLUTION_IMAGES=\""$(datadir)/images/evolution"\" \
- -DEVOLUTION_LOCALEDIR=\""$(localedir)"\" \
- -DEVOLUTION_DATADIR=\""$(datadir)"\" \
- -DEVOLUTION_GLADEDIR=\"$(datadir)/evolution/glade\" \
- -DEVOLUTION_ETSPECDIR=\""$(etspecdir)"\" \
- -DG_LOG_DOMAIN=\"evolution-shell\" \
- $(SHELL_CFLAGS)
+INCLUDES = -O \
+ -I$(top_srcdir)/widgets \
+ -I$(top_srcdir)/widgets/misc \
+ -I$(top_srcdir)/libical/src/libical \
+ -I$(top_srcdir) \
+ $(BONOBO_GNOME_CFLAGS) \
+ $(BONOBO_CONF_CFLAGS) \
+ $(EXTRA_GNOME_CFLAGS) \
+ $(GTKHTML_CFLAGS) \
+ -DEVOLUTION_IMAGES=\""$(datadir)/images/evolution"\" \
+ -DEVOLUTION_LOCALEDIR=\""$(localedir)"\" \
+ -DEVOLUTION_DATADIR=\""$(datadir)"\" \
+ -DEVOLUTION_GLADEDIR=\"$(datadir)/evolution/glade\" \
+ -DEVOLUTION_ETSPECDIR=\""$(etspecdir)"\" \
+ -DG_LOG_DOMAIN=\"evolution-shell\"
# CORBA stuff
IDLS = \
Evolution-Activity.idl \
- Evolution-ConfigControl.idl \
Evolution-Offline.idl \
Evolution-Session.idl \
Evolution-Shell.idl \
@@ -58,10 +60,8 @@ eshellincludedir = $(includedir)/evolution/shell
eshellinclude_HEADERS = \
Evolution.h \
- e-folder-list.h \
e-folder-tree.h \
evolution-activity-client.h \
- evolution-folder-selector-button.h \
evolution-session.h \
evolution-shell-client.h \
evolution-shell-component-client.h \
@@ -76,14 +76,8 @@ eshellinclude_HEADERS = \
libeshell_la_SOURCES = \
$(IDL_GENERATED) \
- e-folder-list.c \
e-folder-tree.c \
- e-shell-corba-icon-utils.c \
- e-shell-corba-icon-utils.h \
evolution-activity-client.c \
- evolution-config-control.c \
- evolution-config-control.h \
- evolution-folder-selector-button.c \
evolution-session.c \
evolution-shell-client.c \
evolution-shell-component-client.c \
@@ -104,38 +98,28 @@ bin_PROGRAMS = evolution
evolution_SOURCES = \
e-activity-handler.c \
e-activity-handler.h \
- e-component-info.c \
- e-component-info.h \
e-component-registry.c \
e-component-registry.h \
- e-corba-config-page.c \
- e-corba-config-page.h \
e-corba-shortcuts.c \
e-corba-shortcuts.h \
e-corba-storage-registry.c \
e-corba-storage-registry.h \
e-corba-storage.c \
e-corba-storage.h \
- e-folder-dnd-bridge.c \
- e-folder-dnd-bridge.h \
e-folder-type-registry.c \
e-folder-type-registry.h \
e-folder.c \
e-folder.h \
e-gray-bar.c \
e-gray-bar.h \
- e-history.c \
- e-history.h \
e-local-folder.c \
e-local-folder.h \
e-local-storage.c \
e-local-storage.h \
e-setup.c \
e-setup.h \
- e-shell-about-box.c \
e-shell-about-box.h \
- e-shell-config.c \
- e-shell-config.h \
+ e-shell-about-box.c \
e-shell-constants.h \
e-shell-folder-commands.c \
e-shell-folder-commands.h \
@@ -149,8 +133,6 @@ evolution_SOURCES = \
e-shell-importer.h \
e-shell-offline-handler.c \
e-shell-offline-handler.h \
- e-shell-settings-dialog.c \
- e-shell-settings-dialog.h \
e-shell-startup-wizard.c \
e-shell-startup-wizard.h \
e-shell-user-creatable-items-handler.c \
@@ -177,6 +159,8 @@ evolution_SOURCES = \
e-storage-set.h \
e-storage.c \
e-storage.h \
+ e-summary-storage.c \
+ e-summary-storage.h \
e-task-bar.c \
e-task-bar.h \
e-task-widget.c \
@@ -189,14 +173,18 @@ evolution_SOURCES = \
evolution-storage-set-view-factory.h \
main.c
-evolution_LDADD = \
- libeshell.la \
- importer/libevolution-importer.la \
+evolution_LDADD = \
+ libeshell.la \
+ importer/libevolution-importer.la \
$(top_builddir)/widgets/e-timezone-dialog/libetimezonedialog.a \
- $(top_builddir)/widgets/misc/libemiscwidgets.a \
- $(top_builddir)/e-util/libeutil.la \
+ $(top_builddir)/widgets/misc/libemiscwidgets.a \
+ $(top_builddir)/e-util/libeutil.la \
$(top_builddir)/libical/src/libical/libical-evolution.la \
- $(SHELL_LIBS)
+ $(EXTRA_GNOME_LIBS) \
+ $(GNOME_PRINT_LIBS) \
+ $(GTKHTML_LIBS) \
+ $(BONOBO_CONF_LIBS) \
+ $(BONOBO_GNOME_LIBS)
# Test component
@@ -208,7 +196,10 @@ evolution_test_component_SOURCES = \
evolution_test_component_LDADD = \
libeshell.la \
- $(SHELL_LIBS)
+ $(EXTRA_GNOME_LIBS) \
+ $(GNOME_PRINT_LIBS) \
+ $(GTKHTML_LIBS) \
+ $(BONOBO_GNOME_LIBS)
install-test-component: evolution-test-component
$(mkinstalldirs) $(DESTDIR)$(bindir)
@@ -223,7 +214,7 @@ oaf_in_files = GNOME_Evolution_Shell.oaf.in
oaf_DATA = $(oaf_in_files:.oaf.in=.oaf)
etspecdir = $(datadir)/evolution/etspec/
-etspec_DATA = e-storage-set-view.etspec e-storage-set-view-checkboxes.etstate e-storage-set-view-no-checkboxes.etstate
+etspec_DATA = e-storage-set-view.etspec
@XML_I18N_MERGE_OAF_RULE@
@@ -232,7 +223,8 @@ EXTRA_DIST = \
$(oaf_in_files) \
$(oaf_DATA) \
$(etspec_DATA) \
- GNOME_Evolution_TestComponent.oaf
+ GNOME_Evolution_TestComponent.oaf \
+ evolution-nognome.in
# Purify support
@@ -254,3 +246,9 @@ BUILT_SOURCES = $(IDL_GENERATED)
dist-hook:
cd $(distdir); rm -f $(BUILT_SOURCES)
+
+if HAVE_DTAPPINTEGRATE
+
+bin_SCRIPTS = evolution-nognome
+
+endif \ No newline at end of file